Channel number issue - CPA black images & not launching edited properties file

Hello! :slight_smile:

I have been using CP 2.1.1 and CPA, with Windows, and am very happy !!! :slight_smile:

Lately I have been trying to classify 8-bit images, that a collaborator gave me, and have 2 channels/ colours. CP works fine, but when I subsequently ‘Fetch’ images in CPA, the thumbnails are black and get a WARNING.

WARNING: CPA found 3 channels in the “Phalloidin” image at xxxx.tif, but it will only load the first 1 as specified by properties field channels_per_image.

I don’t understand why it says that I have ‘3 channels’. I tried to save the images differently, but still get the same WARNING and black thumbnails.
As a solution I decided to go with it and edit the properties file, as follows, but not the CPA will not launch at all. Please note that I do not have ‘dna’ channel/colour, only ‘DAPI’, and ‘Phalloidin’. I was just trying to see if it would work – and it didn’t…

Please help !

ORIGINAL

image_path_cols = Image_PathName_DAPI,Image_PathName_Phalloidin
image_file_cols = Image_FileName_DAPI,Image_FileName_Phalloidin

image_thumbnail_cols = Image_Thumbnail_DAPI,Image_Thumbnail_Phalloidin

image_names = DAPI,Phalloidin

image_channel_colors = red, green

EDITED:

image_path_cols = Image_PathName_DAPI,Image_PathName_Phalloidin, Image_PathName_dna
image_file_cols = Image_FileName_DAPI,Image_FileName_Phalloidin, Image_FileName_dna

image_thumbnail_cols = Image_Thumbnail_DAPI,Image_Thumbnail_Phalloidin, Image_Thumbnail_dna

image_names = DAPI, Phalloidin, dna

image_channel_colors = green, blue, gray

channels_per_image = 3

image_channel_blend_modes = add, add, add

Thank you, in advance !
Sophia

I would guess that each of your images should be only 1 color, but are saved in RGB format. If you open the TIF file in ImageJ/FIJI, how is it described in the upper left? Or is that what you already tried when you tried to save the images differently?

Put another way, I suspect both your DAPI and Phalloidin images have 3 channels. And since R is the first channel in an RGB image, both your green and blue only pictures will be black (no red).

1 Like

Hi Research_Associate,

I appreciate your prompt reply.
My images are 8-bit, not RGB.

Not sure if there is a better Type to save them in.

Thank you,
Sophia

Here is one of the images

WT1_dcenter_c1.tif (4.0 MB)

Thank you,
Sophia

1 Like

Hi @Sophia_Malandraki-Mi,

Is this an input image or an output image from the pipeline?

Could you upload the CellProfiler pipeline you used to create the properties file?

1 Like

Dear Imurphy,

Thank you for your reply!

This is one of the input images, that I uploaded in CP to build the properties file.
I don’t collect any output images; I only use the properties file to classify on CPA afterwards.

(I will upload the pipeline when I am on my other work PC, asap - thank you.)

Thanks,
Sophia

Dear Imurphy,

Here is the pipeline:
Cell_analysis_Feb20.cpproj (79.2 KB)

Thank you for your help!
Sophia

Hi @Sophia_Malandraki-Mi,

Sorry, me again. Could you upload the other channel of the image so I have a full set? Just so then I can see what they look in CPA.

1 Like

Dear Imurphy,

Thank you for taking the time to reply, and try to help with this!

Please see attached both channels for the image.
WT1_dcenter_c1.tif (4.0 MB) WT1_dcenter_c2.tif (4.0 MB)

Thank you, once more!

Sophia

Hi @Sophia_Malandraki-Mi,

Seems your files are a dichotomy, both RGB and not. I can open them with the default Windows viewer and they are coloured blue and green but as you’ve seen, ImageJ thinks they are normal 8-bit. It might be useful to know the journey they go through from the microscope to you via your collaborator because they are slightly odd.

Options for your analysis moving forward if you are happy with the files

  • Open them in FIJI and “change” the type to 8-bit (even though it thought they were already), they will then appear grayscale, re-save them and run the pipeline and everything in CPA will be as your expect.

  • To avoid using two software options, in CellProfiler, tell it in NamesAndTypes that the images are “Color images” then use ColorToGray to split them. To avoid suddenly having 6 images, for the DAPI one, save only the blue image and the red one for Phalloidin. If you do this at the start of your pipeline then your CPA properties file should be as you expect.

Hope that’s help.

2 Likes

Dear Imurphy,

Thank you very much for taking the time to help me out.
Excellent points! I tried the long-way around, of the first bullet-point and it worked!

I will also implement the edits on CellProfiler, as per your second suggestion, for the next images I might receive.

Thank you,
Sophia

1 Like