Centos6 cellprofiler startup (gtk2-unicode)

Hi Forum,

I suffered a windows10 crash last week so I switched to Centos6 (2.6.32-696.3.2.el6.x86_64). After a yum update cellprofiler did not start, I kept getting an error about “$@”. I spent the weekend cleaning up the machine and did a reinstall of many things, now cellprofiler ( I did try the pip install instructions but I keep running into python problems (2.7 and not 2.6?). I have tried to reinstall the RPM and still cellprofiler will not start - now the problems relate to cellprofiler-gtk2-uncode … I have got jdk 1.8.0_92

Uncaught exception in CellProfiler.py
Traceback (most recent call last):
File “/usr/cellprofiler/src/CellProfiler/CellProfiler.py”, line 201, in main
pipeline_path = pipeline_path)
File “/usr/cellprofiler/src/CellProfiler/cellprofiler/cellprofilerapp.py”, line 37, in init
super(CellProfilerApp, self).init(*args, **kwargs)
File “/usr/cellprofiler/lib/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/_core.py”, line 7978, in init
File “/usr/cellprofiler/lib/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/_core.py”, line 7552, in _BootstrapApp
return core.PyApp__BootstrapApp(*args, **kwargs)
File “/usr/cellprofiler/src/CellProfiler/cellprofiler/cellprofilerapp.py”, line 70, in OnInit
from cellprofiler.gui.cpframe import CPFrame
File “/usr/cellprofiler/src/CellProfiler/cellprofiler/gui/cpframe.py”, line 23, in
import cellprofiler.measurements as cpmeas
File “/usr/cellprofiler/src/CellProfiler/cellprofiler/measurements.py”, line 23, in
from scipy.io.matlab import loadmat
File “/usr/cellprofiler/lib/python2.7/site-packages/scipy/io/init.py”, line 83, in
from matlab import loadmat, savemat, byteordercodes
File “/usr/cellprofiler/lib/python2.7/site-packages/scipy/io/matlab/init.py”, line 11, in
from mio import loadmat, savemat
File “/usr/cellprofiler/lib/python2.7/site-packages/scipy/io/matlab/mio.py”, line 15, in
from mio4 import MatFile4Reader, MatFile4Writer
File “/usr/cellprofiler/lib/python2.7/site-packages/scipy/io/matlab/mio4.py”, line 9, in
import scipy.sparse
File “/usr/cellprofiler/lib/python2.7/site-packages/scipy/sparse/init.py”, line 182, in
from csgraph import *
AttributeError: ‘module’ object has no attribute 'csgraph_to_masked’
Load ilastik Core
… more stuff about jvm…
Exception fetching new version information from http://cellprofiler.org/CPupdate.html: HTTP Error 404: Not Found
Exiting the JVM monitor thread

Is there a problem with Centos6 RPMs? I have even tried downgrading cellprofiler…does not work. I even tried the Ubuntu pip install instructions…yeah I know…did not work. Suggestions would be very welcome.

Kind regards, James

@jameschums you may want to consider running CellProfiler from source. There are detailed instructions on how to setup your linux machine at github.

Thank you for the suggestion, I did try using the peculiar Makefile. I had to edit the Makefile rather extensively, remove user id cpbuild, adjust the jdk source installation…when i all worked it still failed on Centos6. I will make a new attempt on a spare laptop that has Centos7 installed, because if I can get that to work then I will upgrade my main number cruncher to centos7. I did manage to adjust the ubuntu pip install method to work with Fedora25 - just out of interest and curiosity. I will spend a few days trying the Makefile method and report back by the end of the week.

Kind regards, James

Can you try upgrading your CP from a 2.1 build to a 2.2 build? 2.1 had older java dependencies, whereas 2.2 should hopefully be easier to install with up-to-date Java builds.

There’s a separate thread here https://github.com/CellProfiler/CellProfiler/issues/2798 in which 3 users report problems starting CellProfiler after performing a Centos6 update. Not sure if its related but there appear similarities.
There is a temporary workaround: booting from a earlier kernel version, but a solution would be very much appreciated (on our cluster reverting to an older kernel version is not possible as it was a security update for Centos6 that apparently broke CP)

1 Like

I rebooted my workstation and selected kernel-2.6.32-696-1.1.el6.x86_64 and uninstalled cellprofiler. Then I did a reinstall of cellprofiler and viola!..( I just remembered a lyric from an old song…‘well I’m blowed hissing sid has swallowed toad’…). Cellprofiler is running again…The reason I had to get the linux version working is because a huge windows10 update last week has left my workstation is a dubious state - it will not shutdown and leaves ntfs drives in a ‘dirty’ state. I will now try to clean the file system and run some cpproj files. Thank you for your help and ‘bsnijder’ links proved rather useful.

Kind regards, James.

1 Like