CellProfiler stops working

I have used CellProfiler for a while, and suddenly it stopped working altogether, even refusing to add any modules in a new pipeline. Deinstalling both MCR and Cellprofiler and reinstalling the latest version solved the problem for a short time (an hour), but now it stopped again, another reinstall and system restart doesn’t help.

System: WinXP 64 bit
CellProfiler version: 1.0.7522, Compiled

ERROR MESSAGE:
??? Error using ==> fgetl at 44
Invalid file identifier. Use fopen to generate a valid file identifier.
Error in ==> CellProfiler>PutModuleInListBox at 8298
Error in ==> CellProfiler>AddModuleListBox_Callback at 11732
Error in ==> CellProfiler>gui_mainfcn at 12633
Error in ==> CellProfiler at 57
??? Error while evaluating uicontrol Callback

Help would be very appreciated,

Martin

Hi Martin,

I would suggest going to File > Preferences to see if CellProfiler is pointed at the correct directories (bottom 3 boxes). If they are pointed in the right place, let us know and we’ll go from there.

Regards,
-Mark

Hi, thanks for the quick reply. Checked the preferences, solved the problem for now. Still I don’t know what happened to this setting - I hadn’t changed it in between, but I will keep an eye on it and get back if needed again,

Martin

I have that problem too after defragmenting my computer, because it reorganizes the position of the files in the registry. I haven’t tried resetting the preferences, which might be an easier solution, but if that doesn’t work try this:

  1. Drag your CompiledCellProfiler folder to another location so you don’t lose anything important.

  2. Go back to the zipped file that you originally downloaded (it’s in the original CompiledCellProfiler folder), unzip it and save it back in the same place that you had the original folder. It should work like the original.

  3. In the future, keep all of your pipelines and other work files in a separate folder outside the CompiledCellProfiler folder so so the CompiledCellProfiler files can be easily swapped out after defragmenting if necessary.

  4. Don’t forget to reset your preferences in the new version.

  5. And if you had a shortcut icon on your desktop in the previous version, delete it and create a new one from the new version of CP.

Thanks for the suggestions! We’ll refer people to this thread if others report similar problems.
-Mark