CellProfiler on 32-bit Linux

cellprofiler

#1

Hi,

I have been running an old version of CellProfiler (Version 1.0.4532) on my 32-bit Linux machine without any problem, but recently decided to update it to the newest version. I first tried the compiled version from your website “Linux (64-bit computers compiled on GNU Linux with an intel processor)”, and got the following error “bash: ./CellProfiler: cannot execute binary file”. My guess is that it was compiled on a 64-bit computer, but I was trying to run it on a 32-bit one. Is that right?

I then downloaded the developer version, and it runs well on within MATLAB, but when I tried to compile it using “mcc -m CellProfiler” command, I got the following error:
/usr/bin/ld: cannot find -lstdc++
collect2: ld returned 1 exit status

mbuild: link of 'CellProfiler' failed.

Error: An error occurred while shelling out to mbuild (error code = 1).
Unable to build executable (specify the -v option for more information).
??? Error executing mcc, return status = 1.

Do you have any idea what I did wrong here?

Thanks a lot!

Tiao


#2

Hi Tiao,

Yes, I assume your compiled CP problem was due to 32 v. 64-bit issues, though I have not tried that experiment specifically. Anybody else there have any experience with this?

As for compiling CP, take a look here: viewtopic.php?f=2&t=405&p=1620&hilit=compiling#p1602
Let us know if this helps.

Cheers,
David