Cellprofiler not working

When I start the program, a FATAL ERROR window appears saying ‘Failed to execute script cellprofiler’.
For your information, I first installed JAVA SE Runtime Environment 8u191 (64bit), followed by Cellprofiler 3.1.5 (64 bit). I ensured to have it installed in Program files (not in Program files (x86)). I would appreciate your valuable suggestions. Thank you.

1 Like

Hi Mohammad,
I am having the same problem. Let us hope they let us know when it is fixed.

1 Like

I also have this problem. Does anybody have an idea on how to resolve this?

I too have had the same problem. Is anyone on the CellProfiler development team working to resolve this? How have other users managed to install CellProfiler successfully?

I am not part of the CP team, but the issue is well known and can be solved. See: Cellprofiler 3.1.5: Failed to execute script CellProfiler


It takes some tinkering around with the Java path and restarting of the computer.


EsbenSv: I have tried the workaround that is posted in your reference. But it did not work for me. Also changing the home value or installing on C: or D: doesn’t fix it.


The Java environment variable thing is important, but if you’re trying to install on a non-C:\ directory you also need to adjust the TEMP directory to something on the drive you want to install to. We’re working to try to fix that!

Thank you! Together with v. 3.1.8 it is now finally working.

1 Like