CellProfiler Neurite analysis and CellProfiler Analyst

Hi all!

I’m working with a dense culture of neural cells where a small proportion of them express fluorescent protein GFP. In each image, I have > 2500 neurons where only ~10 are fluorescent which should help to analyse the morphology of the cells. r01c01f01p01-ch1sk1fk1fl1.tiff (1.9 MB) r01c01f01p01-ch2sk1fk1fl1.tiff (1.8 MB)

I have generated a pipeline that is able to segment the nuclei, neuronal soma and neurites using CellProfiler 4.0.7 and I use the module MeasureObjectSkeleton in order to measure the neurite branching. On top of that, I measure the morphological properties of the cells using the modules measure objectsizeshape, granularity and intensity and finally export all the data to a SQL database to classify the different objects by their morphology using CellProfiler Analyst.neurite_tracing.cppipe (27.5 KB)

I’m finding the following difficulties:

  1. Because the culture is very dense, I can’t manage segment the neurons directly from the nucleus. I tried using the soma of the cells as a mask to reduce the number of nuclei in the field, but I still have 3-4 nuclei in the mask because the cells are very packed. I’m not sure if this is an issue or not since I can still use the XY position of the cell soma as the primary object.

  2. In the module ExportToDatabase, I cannot select the option to export all the measurements to the database. Unless the option selected is “none” the module gives an error.

  3. I am unable to launch CellProfiler Analyst with the output of this pipeline. When I try to load the .properties file, CPA throws an error. test_neurites.properties (6.9 KB)

I would really appreciate any help, comments and criticism on this pipeline :slight_smile:
Thank you everyone in advance!

Hi @dcd93,

Please check your settings in the “ExportDatabase” module. I tried with your pipeline & image set. The properties file created was working in the CPA. Please find the screenshot of the settings. Just one thing, I am not sure about the parameters to choose, so I tried random but you could chose appropriate parameter. You may have to chose “Yes” for both the options marked.

Hope this helps.
Regards,
Lakshmi
www.wakoautomation.com

Thanks for your response Lakshmi,

I’ve tried what you mentioned but still doesn’t work. whenever I try to launch cell profiler analysis I get the following error message:

Maybe it has something to do with the OS that I’m running in my laptop (macOS Big Sur version 11.0.1). I’ve tried to open the example dataset from the CPA website and I get the same error message.

Best,

Dan

Hi @dcd93,

O.k. Sorry for late response. Please check the following threads. It looks there are patch release, may be you could also try that.

Let me know if this works.

Regards,
Lakshmi

Hi again! thanks for the response. Eventually I managed to get CPA to run in my Mac by editing the bash_profile file and manually adding the address of JAVA_HOME. i.e:

nano ~/.bash_profile 

# export JAVA path

export JAVA_HOME="/Library/Java/JavaVirtualMachines/jdk1.8.0_202.jdk/Contents/Home"

It seems like everything is running now as I was hoping for. Thank you again!! :slight_smile: