Cellprofiler installation problem on linux

cellprofiler

#1

Hi Team,

Its being a great pleasure to use CellProfiler for last many months.

I’m now trying to install CellProfiler_1.0.5122 on a linux server

uname -a
Linux endoc1.utmb.edu 2.6.18-92.el5PAE #1 SMP Tue Apr 29 13:31:02 EDT 2008 i686 i686 i386 GNU/Linux

The MCR is also placed in root cellprofiler directory: $home/CellProfiler_1.0.5122/v76

I have set the library path also in .bashrc:
export LD_LIBRARY_PATH=/$home/CellProfiler_1.0.5122/v76/bin/glnxa64/:/$home/CellProfiler_1.0.5122/v76/:/$home/CellProfiler_1.0.5122/v76/runtime/glnxa64/:/$home/CellProfiler_1.0.5122/v76/sys/os/glnxa64/:/$home/CellProfiler_1.0.5122/v76/sys/java/jre/glnxa64/jre1.5.0/lib/amd64/native_threads/:/$home/CellProfiler_1.0.5122/v76/sys/java/jre/glnxa64/jre1.5.0/lib/amd64/server:/$home/CellProfiler_1.0.5122/v76/sys/java/jre/glnxa64/jre1.5.0/lib/amd64/

export XAPPLRESDIR=/$home/CellProfiler_1.0.5122/v76/X11/app-defaults

After doing all these, when I’m executing ./cellprofiler, it gives…
-bash: ./CellProfiler: cannot execute binary file

Im not able to understand it.
Kindly help me out.

Thanks
Mridul KK


#2

Hi Mridul,

A few ideas:
(1) Is this the 5811Bugfix version (the newest on the website)?
(2) The MCR should be v78, not v76
(3) Did you install the MCRInstaller.bin, and not just place it in a directory? Execute the .bin file at the command line.
(4) Have you tried running the run_CellProfiler.sh script? It will do much of the setup work for you.Run it with:

Let us know how it goes,
David


#3

Thanks for yr reply.
I’m using CellProfiler_1.0.5122 on a linux server not the latest one.
It needs v76 as MCRroot.

uname -a
Linux endoc1.utmb.edu 2.6.18-92.el5PAE #1 SMP Tue Apr 29 13:31:02 EDT 2008 i686 i686 i386 GNU/Linux

Well, I tried with new version also and installing MCRInstaller_glnxa64.bin is unsuccessful as it says that either host OS/arch not matching or file is corrupted.

Plz let me know in this regard.
Thanks
Mridul KK


#4

It looks like you are running on a 32-bit Linux architecture. Our cluster is mostly 64-bit machines, and the MCR that was on the CellProfiler website was 64-bit. But I found a 32-bit MCR which you can try. I already added it to our website: cellprofiler.org/download.htm. Again, execute the .bin to install it.

David


#5

Hi David,
Below are the steps that I did to install CP on my linux server (Dell poweredge 2950 III):
uname -a
Linux endoc1.utmb.edu 2.6.18-92.el5PAE #1 SMP Tue Apr 29 13:31:02 EDT 2008 i686 i686 i386 GNU/Linux

I untarred, unzipped CompiledCellProfiler_Linux_5811Bugfix.tar.gz file
and saved at home directory.

Installed the MCRInstaller_glnx86_32bit.bin within CompiledCellProfiler_Linux_5811Bugfix dir.
Got v78.

in .bashrc, i set
export LD_LIBRARY_PATH=/home/mrkalita/CompiledCellProfiler_Linux_5811Bugfix/v78/bin/glnx86:/home/mrkalita/CompiledCellProfiler_Linux_5811Bugfix/v78:/home/mrkalita/CompiledCellProfiler_Linux_5811Bugfix/v78/runtime/glnx86:/home/mrkalita/CompiledCellProfiler_Linux_5811Bugfix/v78/sys/os/glnx86:/home/mrkalita/CompiledCellProfiler_Linux_5811Bugfix/v78/sys/java/jre/glnx86/jre1.6.0/lib:/home/mrkalita/CompiledCellProfiler_Linux_5811Bugfix/v78/sys/java/jre/glnx86:/home/mrkalita/CompiledCellProfiler_Linux_5811Bugfix/v78/sys/os/glnx86:v78/sys/java/jre/glnx86/jre1.6.0/lib/i386/native_threads:/home/mrkalita/CompiledCellProfiler_Linux_5811Bugfix/v78/sys/java/jre/glnx86/jre1.6.0/lib/i386/server:/home/mrkalita/CompiledCel
lProfiler_Linux_5811Bugfix/v78/sys/java/jre/glnx86/jre1.6.0/lib/i386/client:/home/mrkalita/CompiledCellProfiler_Linux_5
811Bugfix/v78/sys/java/jre/glnx86/jre1.6.0/lib/i386:/usr/local:/usr/lib:/home/mrkalita/CompiledCellProfiler_Linux_5811Bugfix/v78/sys/os/glnx86:/usr/include

Also, export XAPPLRESDIR=/home/mrkalita/CompiledCellProfiler_Linux_5811Bugfix/v78/X11/app-defaults

After setting, I ran the command ‘run_CellProfiler.sh v78’ but it terminated…

Looked into run_CellProfiler.sh and found that …it was ‘glnxa64’, so changed it to ‘glnx86’ .
Same way, amd64 was changed to i386.

After doing that all, upon running ‘run_CellProfiler.sh v78’… it says the following…

Setting up environment variables

Found MCR Java JRE version: 1.6.0
LD_LIBRARY_PATH is .:v78/runtime/glnx86:v78/bin/glnx86:v78/sys/os/glnx86:v78/sys/java/jre/glnx86/jre1.6.0/lib/i386/native_threads:v78/sys/java/jre/glnx86/jre1.6.0/lib/i386/server:v78/sys/java/jre/glnx86/jre1.6.0/lib/i386/client:v78/sys/java/jre/glnx86/jre1.6.0/lib/i386
./run_CellProfiler.sh: line 41: ./CellProfiler: cannot execute binary file

Plz let me know, where Im doing wrong. It will be a great-great help.
Thanks
Mridul K


#6

Mridul, I don’t see anything wrong with your procedure - I suspect that the problem is 32/64-bit related. Both the fact that ‘glnxa64’ needed to be translated to ‘glnx86’, plus the “cannot execute binary file” error indicate that the executable just won’t run on your architecture. There do appear to be some 32-bit Linux nodes on our cluster, so I’ll try and compile a 32-bit version soon. I’ll post here again when I’m done.

David


#7

Thanks David.
Will wait for the new compiled version.
Mridul KK


#8

Hi Mridul,

I have tried a number of times to get 32-bit Linux CP compiled, but cannot. The little access we have to a 32-bit machine on our cluster is going offline soon according to out IT department and they are reluctant to support it unless there’s a huge demand (which there is not). Matlab76 does not run on it the 32-bit node, and I tried matlab75 but it does not include mcc, the matlab compiler that we use now. So unless you can get Matlab installed and run the Developer’s version, I think your only option is to upgrade to 64-bit if you want to stay with Linux.

Have you made any other progress?

Cheers,
David