Cellprofiler does not work on Windows Server 2019 for me

Hi there, I am trying to install and run cell profiler 3.1.9 (I also tried an older version with the same result) on a virtual machine (vm-ware) running Windows Server 2019.

While the installation using the standard path works without any problem, I can not run the application.
Just for a second, an error message shows up in the terminal window and then vanishes again.

I would be really thankful if anyone of you has an idea, since the alternative at the moment is, to transfer some 100 gb of image data to my machine at home and later than back to the systems at work.

Thanks and best regards


Hi @ingo_pr,

I understand the issue is with the JAVA enviornment. What JAVA version you have installed?
Can you try start running from the command line?
Also check the JAVA enviornment setting,

It may be worth looking at these links,

Fujifilm Wako Automation (Consultant)
For CellProfiler training or optimised pipeline write to,

Read more on our site.
Yokogawa CV8000 - The Ultimate in Confocal HCS

Dear Lakshmi, thanks for your help.

First of all: I got the problem solved although I am not totally sure which of my attempts made it finally work

According to your hint I checked the java which was installed.

I had the 32 bit JRE as well as a recent JDK.
java -version results in
java version “1.8.0_251”
Java™ SE Runtime Environment (build 1.8.0_251-b08)
Java HotSpot™ 64-Bit Server VM (build 25.251-b08, mixed mode)

What I did was installing the 64 bit JRE.
Then I changed the environmental settings (search for environmental )
in 3 lines

So for CP_JAVA_Home I changed the path to the 64 bit JRE
JAVA_Home and JRH_HOME did not exist and were created by me.

This alone do not chance anything but after a restart of the Windows Server, it worked.

1 Like