CellProfiler database export missing properties file

I would like to use CellProfiler Analyst, but I am having issues with the database export in CellProfiler. When I try to export my analysis to database I only end up with a db file, but CellProfiler does not create a properties file. I am not quite sure what causes this. Any advice?

Hi Anna,
Are you choosing the Database type as SQLite? and having Yes selected for the “Create a CellProfiler Analyst Properties file”?

If you’re already doing the above and still no properties file is created, please provide additional information, your pipeline and some sample images, so we can have a closer look.

Hi Nasim,

Thank you for the help. Indeed I did no select the option to create the properties file. Such a silly mistake.
However, now I encountered an other issue where CellProfiler Analyst would not open after selecting the properties file. It just flashes and disappears.
I think the problem is within my pipeline. I attach it here with some images.
Micronuclei_Count_20200609.cpproj (1.2 MB)
Archive.zip (4.5 MB)

Can you explain what you’re trying to detect and measure?

I would like to quantify cells with and without micronuclei. For this, I’ve tried to measure and identify both the nuclei and the micronuclei and relate them (without cytoplasmic marker it seems a bit more complicated so I used a blown up nucleus to see which micronucleus could belong to which nucleus).

You could use the IdentifyPrimaryObject to detect the nuclei (no need for all of the steps before the first IPO) and do the same for micronuclei (only define the proper size).
Detection_Test.cppipe (13.1 KB)

The MeasureColocalization and CalculateMath modules in your pipeline are still not clear, and if you see the results of MeasureColocalization, it’s all 1 (ignore the Manders coeff).

Also, you mentioned you want to quantify “cells” which is not possible here since there is no other marker than the nuclei one, so when cell is the expanded version of the nuclei (specially here that thresholding was done before and all the background pixel is 0), then you’re just detecting some 0 intensity values as your cells.

For your original question (CPA), what’s your operating system and its version?
Please take a look at this.

So I assumed I need to relate the two different objects (nucleus and micronuclei) somehow and for that I could use a third object which encapsulates both of them. But maybe I need to do it a different way.
I thought I don’t need the intensities for the cells, since I just want to detect them. I am not entirely sure what measurements should I be taking.

For CP I use 3.1.9 on a Mac, but since I could not make it work (even with the help from the topic you are referring to) I used CPA 2.2.1 on a windows system.