CellProfiler Analyst Download Issue

After downloading and installing both CellProfiler-Analyst and Java8 JDK, I am still getting an error message pop-up when I try to run CPA. This is the error message in my CellProfiler-Analyst.exe.log file:

No handlers could be found for logger “javabridge.locate”
Traceback (most recent call last):
File “CellProfiler-Analyst.py”, line 19, in
File “javabridge_init_.pyc”, line 28, in
Copyright © 2009-2013 Broad Institute
File “javabridge\jutil.pyc”, line 137, in
the script has run, the values of these
File “javabridge\jutil.pyc”, line 125, in _find_jvm

javabridge.jutil.JVMNotFoundError: Can’t find the Java Virtual Machine
No handlers could be found for logger “javabridge.locate”
Traceback (most recent call last):
File “CellProfiler-Analyst.py”, line 19, in
File “javabridge_init_.pyc”, line 28, in
Copyright © 2009-2013 Broad Institute
File “javabridge\jutil.pyc”, line 137, in
the script has run, the values of these
File “javabridge\jutil.pyc”, line 125, in _find_jvm

javabridge.jutil.JVMNotFoundError: Can’t find the Java Virtual Machine
No handlers could be found for logger “javabridge.locate”
Traceback (most recent call last):
File “CellProfiler-Analyst.py”, line 19, in
File “javabridge_init_.pyc”, line 28, in
Copyright © 2009-2013 Broad Institute
File “javabridge\jutil.pyc”, line 137, in
the script has run, the values of these
File “javabridge\jutil.pyc”, line 125, in _find_jvm

javabridge.jutil.JVMNotFoundError: Can’t find the Java Virtual Machine
No handlers could be found for logger “javabridge.locate”
Traceback (most recent call last):
File “CellProfiler-Analyst.py”, line 19, in
File “javabridge_init_.pyc”, line 28, in
Copyright © 2009-2013 Broad Institute
File “javabridge\jutil.pyc”, line 137, in
the script has run, the values of these
File “javabridge\jutil.pyc”, line 125, in _find_jvm

javabridge.jutil.JVMNotFoundError: Can’t find the Java Virtual Machine

Any ideas what I need to do to help the program find the JDK?

Hi @egrody,

Here are few threads which might of help and had a similar issues, You might have to set the path of JDK.

Hope this helps!!

Regards,
Lakshmi
Fujifilm Wako Automation (Consultant)
www.wakoautomation.com
For CellProfiler training or optimised pipeline write to,
lakshmi.balasubramanian.contractor@fujifilm.com

Read more on our site.
Yokogawa CV8000 - The Ultimate in Confocal HCS
https://www.wakoautomation.com/products/yokogawa-high-content-imaging

Join us at, https://www.slas2020.org

Hi Lakshmi,

This was very helpful! I wound up creating a new JAVA_HOME path and that solved the problem. Thank you!

1 Like