CellProfiler(4.0.7) ValueError during Run of Module MeasureImageQuality

Hi, CellProfiler Team and everyone
Today I upgraded my pipeline from CP 3.1.9 to CP 4.0.7. The new pipeline works well on my own computer and runs faster than on CP 3.1.9. But when I try to run it on another computer, a ValueError occurs in the MeasureImageQuality module. If I don’t calculate blur metrics, this error will not happen. The operating systems of both computers are all window 10. My own computer is a Chinese version of the window operating system, the other is an English system.
Here is the error log information:
Error Message


Here is my pipeline and images:
analysis_test.cppipe (7.2 KB)
test_B02_s1_w1.TIF (8.0 MB)
test_B02_s1_w2.TIF (8.0 MB)
If you can provide me with any suggestions about this error, I would really appreciate it!
Thank you very much!

Hi @Gavyn,

I’ve not been able to replicate this error when running the pipeline on an English Windows 10 system running CellProfiler 4.0.7. Are the examples you uploaded definitely the specific images which trigger the error?

Hi, @DStirling,
Thank you very much for your reply. I have tried many ways, but I still can’t avoid this error. What I can confirm is that every image on that computer will trigger this error. By the way, someone reported the same error on github (https://github.com/CellProfiler/CellProfiler/issues/4271). If I ran the MeasureImageQuality module on CP 3.1.9, I would get the following warning message:


I don’t know if this warning is related to the error.