CellProfiler 4.0.5 Not Launching on MacOS 10.13.6

I’m a huge fan of CellProfiler, but I recently tried to upgrade to the newer v4.0.5, however I can never get it to launch on my Mac (10.13.6). I’ve followed the instructions from the website, but as soon as it launches it crashes. Until I find a solution, I’m continuing to use v3.1.9, which continues to work very well.
Thanks for any help.

Same issue here with MacOS 10.15.6

Finally it works if I run it directly from the Downloads folder (without moving it to the Applications folder) maybe you should try?

Same issue with MacOS 10.12.6. Opening from the Downloads folder does not work for me.

Sorry, on looking into this, our build system for 4.0.X only supports 10.14+; we’ve now added a note to the website.

It may be possible to install from source (which is MUCH easier in CP4 than it was in CP3); we’re not certain how far back in MacOS versions all the various packages CellProfiler needs are supported, but that would be the only other way to upgrade for those operating systems. Very sorry for the inconvenience!

1 Like

Hey yes. So I deleted CellProfiler 4.0.5 from the Applications Folder and emptied the trash bin. Then I re-downloaded the CellProfiler 4.0.5 on my macOS 10.15.7 and started it (from the Downloads folder). After bypassing the developer identity at Privacy settings, the CellProfiler is working fine from the downloads folder even after closing and re-opening the app.

I faced the same issue with Mac OS 10.15.7 and was able to get CellProfiler4.0.5 to open by deleting the application from the Applications folder, re-downloading the zip file and extracting it to the Downloads folder.

Thanks for the suggestions.

CellProfiler 4.1.3 Not launching on Windows 10. (Cellprofiler starup error: could not finfd path to java enviroment directory). We followed the instructions and installed Java and still won’t run.
Thanks for your help…

Hi @Guti,

Are you running from source or a downloaded build?

Hi DS:
I downloaded the program to my computer…

How exactly did you download the program?

Would you also be able to upload a screenshot of your system environment variables?