CellProfiler 3.1.8 won't open after installation

Hi! I’m a new user and tried to install CellProfiler 3.1.8. When trying to opening the program, it would immediately crash. Upon recommendation from a more seasoned user, I uninstalled that version and opted for version 2.2.1, which works perfectly.

Windows 7, 64-bit OS
java version 1.8.0_201
Java ™ SE Runtime Environment (build 1.8.0_201-b09)
Java Hotspot ™ 64-bit server VM (build 25.201-b09, mixed mode)

I encountered the same issue you had. Version 2.2.1 runs with no problem. What I did was to set the environment variable as instructed. (Control panel > System and Security > System > Advanced system settings > environment variables) Set to the correct path for your installed JRE folder. It worked out for me.

we experienced also the same. We can start as admin but not as normal user. No JRE is installed on the PC indicating that under admin CP finds somewhere java.

I just want to add some more details how we solved as suggested by @shirleyszp.

Cellprofiler 3.1.8 is shipped with java. The environment variable that points to it is CP_JAVA_HOME = C:\Programs Files (x86)\CellProfiler\java. It seems that the variable is only set for the admin but not as system variable. If you type in the windows command SET CP_JAVA_HOME it does not find anything.

Go to the environment settings as described by @shirleyszp and add the CP_JAVA_HOME as system variable. No JRE extra installation is required.

@CellProfilerTeam May be this issue can be fixed at startup?



Hello Everyone,
I am facing the same problem. I tried the offered solutions but it could not solve the issue. I am using Windows 10 home. Please help. I have added the screenshot of the settings.


Can you kindly help me to install it?

see the related thread here (if you missed it):

In the thread two unrelated issues preventing the startup are discussed:

  • system locale settings (font encoding errors)
  • java environment variables

@Twinkle I did only set the Environment variables as you described. Try also the other issues. Call cellprofiler from the command line to see the error. You may also need to restart the software.

I have met a new problem when opening the software, the cmd window shows “unicode decode error ascii codec can’t decode byte 0xcb” then it closes. Does anyone know how to fix this? I have installed the latest version of Java 8 and tried methods mentioned above. Thanks!