CellProfiler 3.1.8 - Startup Issue

I am an avid user of CP software for some time, however recently I have had trouble starting up CP 3.1.8 or CP 2.2 on one particular computer (which implies to me that there is a problem with the set up there).

I hoped someone may be able to point me in the right direction of how to solve this problem. After starting to run 3.1.8 I receive the following error message and the terminal window just hangs without proceeding (CP2.2 starts to run, displays some kind of error and the terminal closes quickly without time to see the error message):

Traceback (most recent call last):
File “CellProfiler.py”, line 8, in
File “CellProfiler\cellprofiler_main_.py”, line 162, in main
File “CellProfiler\cellprofiler\gui\app.py”, line 55, in init
File “site-packages\wx-3.0-msw\wx_core.py”, line 8628, in init
File “site-packages\wx-3.0-msw\wx_core.py”, line 8196, in _BootstrapApp
File “CellProfiler\cellprofiler\gui\app.py”, line 62, in OnInit
File “CellProfiler\cellprofiler\gui\cpframe.py”, line 328, in init
File “CellProfiler\cellprofiler\gui\cpframe.py”, line 1143, in __attach_views
File “CellProfiler\cellprofiler\gui\pipelinecontroller.py”, line 103, in init
File “CellProfiler\cellprofiler\gui\pipelinecontroller.py”, line 1272, in populate_recent_files
File “site-packages\wx-3.0-msw\wx_core.py”, line 12007, in Append
wx._core.PyAssertionError: C++ assertion “Assert failure” failed at …\src\common\stockitem.cpp(213) in wxGetStockLabel(): invalid stock item ID
[11552] Failed to execute script CellProfiler

Thanks in advance!

Hi CaptainKinase,

I am not sure if you are using Windows/Linux/Mac. If windows, try uninstall and reinstall again but it is it Ubuntu follow steps in this link,


For Mac,
check these links
https://forum.image.sc/search?q=cellprofiler%20mac

Regards,
Lakshmi
Fujfilm Wako Automation (Consultant)
www.wakoautomation.com

Hi Lakshmi,

I am currently using Windows and still have the issue despite uninstall/reinstall and trying the new 3.1.9 version.

At a bit of a loss of what else to try to solve it. Any other suggestions?

Thanks!

Hi CaptainKinase,

It would be helpful if you share the screen shot of the error or the message that comes in the command window. Was it same as mentioned earlier in this thread?
Hope you have done the installation in C:/ drive, if not you have to set up the enviornment as mentioned here.
In addition, as mentioned in few of the below threads, you can install 3.0 and then install 3.1.8, Because this might solve if there is any JAVA issues.
Also it might worth checking these threads,


@bcimini
Regards,
Lakshmi
Fujifilm Wako Automation (Consultant)
www.wakoautomation.com
Join us at the High Content Analysis Symposium Oct 21-22, London

Society for Laboratory Automation and Screening

SLAS 2019 Advanced 3D Human Models and High-Content Analysis Symposium

Read more on our site.

Yokogawa CV8000 - The Ultimate in Confocal HCS
https://www.wakoautomation.com/products/yokogawa-high-content-imaging

A couple more questions, because that is a puzzling stack trace (thank you for providing by the way!)-

-Are you installing from source, or downloading the executable from our website?
-Do you have admin permissions on this machine?
-Are you installing on the C: drive, and are there any non unicode/non English characters in the installation path?

Hi Lakshmi/Beth,

I tried the recommendation of installing back to 3.0 (+ Java8u221) and I checked to make sure that JAVA_HOME was set to the correct location (both were installed on C: drive on a pc I have admin rights to).
In this case 3.0 would still not run (disappears quickly after running)

I installed 3.1.9 again in any case and get the same log disappearing after trying to run, when screen grabbing it comes up with a slightly different error log:

Traceback (most recent call last):
File “CellProfiler.py”,line 3, in
File “c:\python27\Lib\site-packages\PyInstaller\loader\pyimod03_importers.py”, line 395, in load_module
File “CellProfiler\cellprofiler_main_.py”,line 13, in
File “c:\python27\Lib\site-packages\PyInstaller\loader\pyimod03_importers.py”, line 395, in load_module
File “site-packages\bioformats_init_.py”,line 21, in
File “c:\python27\Lib\site-packages\PyInstaller\loader\pyimod03_importers.py”, line 395, in load_module
File “site-packages\javabridge_init_.py”,line 38, in
File “c:\python27\Lib\site-packages\PyInstaller\loader\pyimod03_importers.py”, line 395, in load_module
File “site-packages\javabridge\jutil.py”, line 157, in
File “c:\python27\Lib\site-packages\PyInstaller\loader\pyimod03_importers.py”, line 395, in load_module
ImportError: DLL load failed: %1 is not a valid Win32 application.
[4748] Failed to execute script CellProfiler

If i remove JAVA_HOME and leave CP_JAVA_HOME, then it reverts back to the original error message (though a slight different code in end line):

Traceback (most recent call last):
File “CellProfiler.py”, line 8, in
File “CellProfiler\cellprofiler_main_.py”, line 162, in main
File “CellProfiler\cellprofiler\gui\app.py”, line 55, in init
File “site-packages\wx-3.0-msw\wx_core.py”, line 8628, in init
File “site-packages\wx-3.0-msw\wx_core.py”, line 8196, in _BootstrapApp
File “CellProfiler\cellprofiler\gui\app.py”, line 62, in OnInit
File “CellProfiler\cellprofiler\gui\cpframe.py”, line 328, in init
File “CellProfiler\cellprofiler\gui\cpframe.py”, line 1143, in __attach_views
File “CellProfiler\cellprofiler\gui\pipelinecontroller.py”, line 103, in init
File “CellProfiler\cellprofiler\gui\pipelinecontroller.py”, line 1272, in populate_recent_files
File “site-packages\wx-3.0-msw\wx_core.py”, line 12007, in Append
wx._core.PyAssertionError: C++ assertion “Assert failure” failed at …\src\common\stockitem.cpp(213) in wxGetStockLabel(): invalid stock item ID
[1476] Failed to execute script CellProfiler

Please let me know if I can provide any other info?

Thanks!