Cellprofiler 3.1.5: Failed to execute script CellProfiler

Hi all,

After receiving a new computer at work I attempted to install Cellprofiler 3.1.5. Windows 10, no java installation. When trying to start CellProfiler, the CPU runs for a while before coming up with the error message:

image

I don’t seem to be getting any error messages or other information when starting in a command prompt, just this message. I have to go through IT to install/uninstall programs, so testing options are a bit limited. Any ideas?

Hi @Kai_B,

A similar thread is open here:

I have the same issue on windows 7 with the exact same error message. Any help is appreciated.

Hi,

The workaround posted in the thread above by djpbarry worked for me as well (I did not alter any environmental variables though). To recap, I uninstalled CP 3.1.5, installed java 1.8 and CP 3.0.0, and confirmed that this was working. Then I installed CP 3.1.5 on top of that, and that also works now (I still have java installed now, not sure if that matters, I did not test if this worked without the extra java install).