CellProfiler 3.0 error in Wathershed: numpy boolean substract operator is deprecated

cellprofiler
segmentation
python

#1

Hi,
I am very new to CellProfiler, but have been struggling for a long time with the following error when trying to to 3D nuclei and cell segmentation:
Error while processing Watershed: numpy boolean substract, the ‘-’ operator, is deprecated, use the bitwise_xor, the ‘^’ operator, or the logical_xor function instead.

I have been following step-by-step several CellProfiler tutorials, such as this one (https://github.com/CellProfiler/tutorials/blob/master/3d_monolayer/3d_monolayer_final.cppipe) and this is where I get the error above.

As a result, the segmentation process is very incomplete and I can’t get any results.

Do you know where exactly is the problem?

Thanks in advance,

Lorena


#2

I have the same problem. It looks like there something with python.
I tried to run the project with the images from the repository. without any change of the pipeline settings, everything work well until it reach the watershed. Cell profiler send the same message. This suggest a problem with the module itself.
Best,
Eric


#3

Hi,

Can you try upgrading to 3.1.5 and see if the problem persists? I believe we have already fixed this bug.


#4

Hi, I am not sure it corrected because I still have this error on 3.1.5.
The weird things is that the problem occurs with MacOS. I have compiled the same version on another machine running Ubuntu 18 and I don’t have this problem. The module is running fine.
Best
ED


#5

Hi all,

I kind of got around the issue by totally uninstalling python3 AND Anaconda from my mac laptop.

I read somewhere that CellProfiler is designed to work with python2, but I do wonder how this has an effect when we use the CellProfiler interface (does it require to have python pre-installed at all?)

Lorena


#6

Hi, I have the same problem, but since I really would not want to uninstall Anaconda, I wonder whether there is a real solution for this?
Maybe it is due to the fact that I installed Visual Studio 2017 ? I feel like Cell Profiler worked fine for a few moments before this problem started arising…


#7

I have to say that in my case, the problem is not from Watershed but ExportToDatabase module, which I don`t know where to find. And I am using CellProfiler 3.1.5