Cellprofiler 3.0.0 not working - Java problem?



My boss asked me to download this program but it doesn’t seem to work on my laptop. At first I believed the reason was I didnt have java installed so I installed java (although I am not sure if it is working either since only web browser I have is Edge, which doesn’t support Java)
I believe I should have java installed now (it is sitting in the folder but I have no programs that can use it) and I have re-installed CellProfiler 3.0.0 several times but it never launch. It just gives the error seen in the picture and closes.



CP3.0 doesn’t work with Java 9.0.
Can you please check the version you’ve installed. Type this in cmd:

java -version

Uninstall Java 9.0 if you have, download and re-install Java 8 at http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html

Good luck.



I am having the same problem. I have installed Java 8.0 and now installed CellProfiler 3.0 but I get the same failure message as Ollain shows above. Has this problem been resolved if so what can I do to get CellProfiler to work on my computer.




I am having the same problem…



Is it possible that you’ve installed CellProfiler first and then installed Java? I had the same problem despite having java 1.8.0_161 installed.
I uninstalled CellProfiler and double checked Java (both x86 and 1.8) and checked the file destination was correct and then reinstalled CellProfiler and its fixed.


I’ve tried it, but still doesn’t work…
Any other suggestions?



Can you post the output of typing java -version in the terminal? Thanks.


I was worried about that too so I uninstalled everything and reinstalled Java 8 first then CellProfiler but still have the same problem.


I used the recommended link from the Cellprofiler website to download this version of Java, before I downloaded the Cellprofiler program. I tried to post a screenshot of the output but I can’t so it says…
“Version 8 Update 161 (build 1.8.0_161-b12)”

  1. What OS are you on? If Mac, make sure you have the JDK installed
  2. If you previously had Java 9 installed and had to roll back to 8, can you follow the advicein this thread? Thanks!


I had the same problem but solved it by installing the 64-bit version of Java (installed in C:\Program files\ instead of C:\Program files(x86) directory). It seemed that my windows originally had Java 32-bit version (I didn’t bother uninstalling this).

Then I reinstalled cell profiler (also placed in C:\Program files). The original default was C:\Program files(x86).

Hope this helps.


I finally got it to work.
I think the problem was that I had installed Java and CellProfiler on E-drive. After re-installing the programs a several times I decided to try and installed both of them on my C-drive and it runs now.

This bothers me a little since the C-drive in my computer is a small SSD card which I would not want to use for this kind of programs. I have a 1000Gt E-drive for that…


Thanks so much for reporting back a solution (even if non-optimal!)