CellProfiler 3.0.0 Linux defaults to headless

cellprofiler

#1

I am installing CellProfiler under Linux in a Singularity container. Everything works, except it doesn’t display the user interface. Running on debug displays a message that it is running in headless mode for awt.

I have tried the environment variable CELLPROFILER_USE_XVFB=1 to force it, but it seems permanently set.

Thanks in advance

Jonas Lindemann


#2

Hello!

Are you running singularity on a cluster node over SSH or on your local machine? I don’t have much experience with Singularity, but if it is similar to Docker you may have to specify some settings in order to tell the container to forward the X-server:



#3

I solved it. When running in the singularity container, the xauth cookie was not visible. I added the directory as a bind to the singularity command, then it worked.

Jonas


#4

Hi Jonas,

not related to your original question but I’m wondering whether you have a build recipe for a CP 3 singularity image that you would be happy to share?