CellProfiler 3.0.0 installation issues



@allen_goodman Sure thing - I downloaded at 4:10 pm. The version I get once installed in Applications is from yesterday 3:14 pm though (325 MB).

It’s unsigned.
It continues to give the ‘cannot find pipeline’ error.
It processes the welcome screen pipeline just fine, though.

LMK what else I can do!


@Terje Try re-downloading. I updated the build to fix this problem.


@Gaurav_Joshi Is there a particular reason you have not upgraded to 10.12 or 10.13?


That worked , CellProfiler is now running on my MacOS 10.13 (17A405).
I did get a error message, see 51 PM

I am brand new to CellProfiler so not sure if this error is expected ?


I also get a “error loading pipeline” on the “Welcome to CellProfiler!” “see a pipeline in action” link

54 PM


I have a perfectly running old mac book pro which according to Apples standard is obsolete. Based on my hardware I am only eligible for upgrades till 10.11
Hence stuck in this version.


if this may help, had the same “bouncing then disappearing icon” issue yesterday, re-downloaded the installer indicated above this morning and everything seems to be working fine on High Sierra 10.13


Awesome. I appreciate the update.


Hi, @Gaurav_Joshi, I updated the build. CellProfiler should now work on 10.11. Let me know.


Works like a charm. Thanks much.


Awesome! Thanks for the update.


I tried to install CellProfiler3.0.0rc7 into My MacBook pro few days ago according to the description above. It worked wells at that time.

However, I tried source installation today in order to use machine learning plug-in. Java was updated from JDK8 to JDK9 and I could not install CellProfiler…

The error message said

Command “python setup.py egg_info” failed with error code 1 in /private/var/folders/2k/wbhtc0_93lv1z5bwxmbgmflh0000gn/T/pip-build-hmly2d/javabridge/

I also tried to install CellProfiler again from CellProfiler3.0.0rc7.dmg but I got the error message as below.

I suppose there is an issue of compatibility of CellProfiler to newer version of JDK. Is there any way to fix it? Thanks,


No handlers could be found for logger "javabridge.locate"
Could not find Java JRE compatible with x86_64 architecture
Could not find Java JRE compatible with x86_64 architecture
Traceback (most recent call last):
File “javabridge/jutil.py”, line 273, in start_thread
File “javabridge/jutil.py”, line 125, in _find_mac_lib
UnboundLocalError: local variable ‘cmd’ referenced before assignment
Failed to create Java VM
Traceback (most recent call last):
File “CellProfiler.py”, line 8, in
File “cellprofiler/main.py”, line 152, in main
File “cellprofiler/gui/app.py”, line 53, in init
File “cellprofiler/utilities/cpjvm.py”, line 102, in cp_start_vm
File “javabridge/jutil.py”, line 314, in start_vm
RuntimeError: Failed to start Java VM
[924] Failed to execute script CellProfiler


I figured out a temporary solution. I could uninstall the newer version of JDK as this https://docs.oracle.com/javase/8/docs/technotes/guides/install/mac_jdk.html

cd /Library/Java/JavaVirtualMachines


sudo rm -rf jdk-9.0.1.jdk

After that, it works fine!


Hi I have another question for source installation for CellProfiler.
Installation was done successfully.

However, it is impossible to run CellProfiler from terminal.

The error message is as below:

Traceback (most recent call last):
File “/anaconda/bin/cellprofiler”, line 11, in
load_entry_point(‘CellProfiler’, ‘console_scripts’, ‘cellprofiler’)()
File “/Users/toshihikooki/CellProfiler/cellprofiler/main.py”, line 136, in main
import cellprofiler.gui.app
File “/Users/toshihikooki/CellProfiler/cellprofiler/gui/app.py”, line 12, in
import wx

I suppose wxpython was not linked correctly to the CellProfiler.
I tried to

brew link wxpython

But it did not work.
Please let me know if there is any suggestion!
Thanks again,



Yeah. CellProfiler is not compatible with Java 9. We expect to have Java 9 support by 3.0.1.


Since “upgrading” to OSX 10.13.1 this morning I have not been able to launch CellProfiler3.0.0 - installed Java for OSX Legacy as this is needed for other programs and updated JVE to latest version. Also discarded CP and reinstalled, same result. I got a "verifying CP"progress bar then nothing. What is going on?


Hi puresp,

Can you confirm whether or not your Java is version 8 or version 9? Thanks.


Hi, I use CP since V1, then V2 and all updates in between, never had any issue installing them, but for whatever reason I am entirely unable to get CP3 up and running. Did countless installs, still no luck. I have installed JRE with the link provided (it’s the v8, not 9), but regardless of where I install, path, uninstall CP2 before or not, I always end up with this when I try to start CP3:

File “c:\users\admini~1\appdata\local\temp\2\pip-build-wsqbac\pyinstaller\PyIn
staller\loader\pyimod03_importers.py”, line 389, in load_module
File “CellProfiler\cellprofiler\modules_help.py”, line 235, in
File “CellProfiler\cellprofiler\modules_help.py”, line 223, in _image_resour
File “ntpath.py”, line 529, in relpath
ValueError: path is on drive D:, start on drive C:
Could not load cellprofiler.modules.loadimages
Traceback (most recent call last):
File "CellProfiler\cellprofiler\modules_init
.py", line 321, in add_module
File “c:\users\admini~1\appdata\local\temp\2\pip-build-wsqbac\pyinstaller\PyIn
staller\loader\pyimod03_importers.py”, line 389, in load_module
File “CellProfiler\cellprofiler\modules\loadimages.py”, line 107, in
File “c:\users\admini~1\appdata\local\temp\2\pip-build-wsqbac\pyinstaller\PyIn
staller\loader\pyimod03_importers.py”, line 389, in load_module
File “CellProfiler\cellprofiler\modules_help.py”, line 235, in
File “CellProfiler\cellprofiler\modules_help.py”, line 223, in __image_resour
File “ntpath.py”, line 529, in relpath
ValueError: path is on drive D:, start on drive C:

And similar messages for quite a lot more pages. I do the install on drive C, have nothing on D. Would be great to get this up and running, I’ve been trying to update to CP3 since a while, but every time I download hoping a miraculous update would have solved it, i still get stuck the same way. Thanks!



Do you potentially have your temp or other folder CP would be trying to access pointed at D:? See here for a potentially related post.


That was exactly the issue, the temp drive was set on a separate hard drive, thanks for the help. This is brilliant. Any way of making this work without constraining the temp folder path by any chance? There are plenty good reasons to be able to set windows temp drive independently from the requirements of CP!