CellProfiler 3.0.0 installation issues



I saw this issue raised somewhere else, but I tried all suggestions there. I’m running a mac0s 10.12. I installed wxpython both on the systems python and my anaconda installation, but no joy. I also did java 8 114 update. So I think I have done everything suggested on the post. Do you have any new ideas?


@MarcKobudo, have you tried:


Let me know.



I had not tried it, but have now downloaded. Same problem: it bounces in the dock and then disappears.


Interesting. Would you mind trying the following:

  1. Drag CellProfiler.app from the CellProfiler.dmg to your desktop
  2. Run the following command from Terminal:

If CellProfiler crashes you should see some output in the Terminal.

Come back and let me know what it says. :slight_smile:



indeed that was much more verbose. I hope this tells you more.
thanks for looking into this,

tds-mac:~ bickle$ /Applications/CellProfiler.app/Contents/MacOS/CellProfiler
Traceback (most recent call last):
File “CellProfiler.py”, line 8, in
File “cellprofiler/main.py”, line 136, in main
File “/private/var/folders/_3/nmjl0qjn3bl6bp9qdll84tc18fpk6c/T/pip-build-SPZ6VW/pyinstaller/PyInstaller/loader/pyimod03_importers.py”, line 396, in load_module
File “cellprofiler/gui/app.py”, line 12, in
File “/private/var/folders/_3/nmjl0qjn3bl6bp9qdll84tc18fpk6c/T/pip-build-SPZ6VW/pyinstaller/PyInstaller/loader/pyimod03_importers.py”, line 396, in load_module
File “wx-3.0-osx_cocoa/wx/init.py”, line 45, in
File “/private/var/folders/_3/nmjl0qjn3bl6bp9qdll84tc18fpk6c/T/pip-build-SPZ6VW/pyinstaller/PyInstaller/loader/pyimod03_importers.py”, line 396, in load_module
File “wx-3.0-osx_cocoa/wx/_core.py”, line 4, in
File “/private/var/folders/_3/nmjl0qjn3bl6bp9qdll84tc18fpk6c/T/pip-build-SPZ6VW/pyinstaller/PyInstaller/loader/pyimod03_importers.py”, line 687, in load_module
ImportError: dlopen(/var/folders/4c/vxwnqt_d2sz2yk2n79_bw37m0000gp/T/_MEISdpKdu/wx.core.so, 2): Library not loaded: @loader_path/libwx_osx_cocoau_xrc-3.0.dylib
Referenced from: /var/folders/4c/vxwnqt_d2sz2yk2n79_bw37m0000gp/T/_MEISdpKdu/wx.core.so
Reason: image not found
[9666] Failed to execute script CellProfiler


@MarcKobudo It looks like CellProfiler is confused by your wxPython installation. How did you install wxPython? Do you have multiple copies installed?


well I saw a post by others having difficulties and so I installed it on the systems python and my anaconda installation. But looking at the results of locate it seems it is only in the anaconda. Should I point and install to the system python?



CellProfiler bundles a copy of Python so the conflict probably isn’t with your system Python.

If you have Homebrew installed, would you mind trying:

$ brew install wxpython


You should also try running the stable version that was released this morning:




brew install wxPython does not work. It starts with a warning about 10.12 being not yet supported
You are using OS X 10.12.
We do not provide support for this pre-release version.
You may encounter build failures or other breakages.

indeed it does break
checking for mawk… no
checking for nawk… no
checking for awk… awk
checking whether make sets $(MAKE)… yes
checking whether make supports nested variables… yes
checking whether ln -s works… yes
checking for style of include used by make… GNU
checking for gcc… clang
checking whether the C compiler works… yes
checking for C compiler default output file name… a.out
checking for suffix of executables…
checking whether we are cross compiling… configure: error: in /private/tmp/xz20171016-10847-xupa9/xz-5.2.2': configure: error: cannot run C compiled programs. If you meant to cross compile, use–host’.
See `config.log’ for more details
Trying to start the stable release failed too. Here is the console output
Process: cp [11442]
Path: /Applications/CellProfiler.app/Contents/MacOS/cp
Identifier: org.cellprofiler.CellProfiler
Version: 3.0.0
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: cp [11442]
User ID: 502

Date/Time: 2017-10-16 23:50:54.719 +0200
OS Version: Mac OS X 10.12.5 (16F73)
Report Version: 12
Anonymous UUID: 9985CAB5-5139-0724-F9C5-4B5661130A9D

Sleep/Wake UUID: 9DA8A3CA-C571-4638-802D-D8EDFE077CF2

Time Awake Since Boot: 83000 seconds
Time Since Wake: 1400 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Codes: 0x0000000000000001, 0x0000000000000000

Termination Signal: Illegal instruction: 4
Termination Reason: Namespace SIGNAL, Code 0x4
Terminating Process: exc handler [0]

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 Python 0x0000000104c30773 file_new + 100
1 Python 0x0000000104c2f6b9 PyFile_FromFile + 46
2 Python 0x0000000104cbb940 _PySys_Init + 165
3 Python 0x0000000104cb528b Py_InitializeEx + 253
4 org.cellprofiler.CellProfiler 0x0000000103a094b2 0x103a05000 + 17586
5 org.cellprofiler.CellProfiler 0x0000000103a07b76 0x103a05000 + 11126
6 org.cellprofiler.CellProfiler 0x0000000103a07fc0 0x103a05000 + 12224
7 org.cellprofiler.CellProfiler 0x0000000103a06634 0x103a05000 + 5684

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000104dc30c0 rbx: 0x0000000104d162f0 rcx: 0x0000000104d1dee8 rdx: 0x0000000000000000
rdi: 0x0000000104dc3110 rsi: 0x0000000000000000 rbp: 0x00007fff5c1f8da0 rsp: 0x00007fff5c1f8d90
r8: 0x0000000104da6eb0 r9: 0x3bc7af196991ef2d r10: 0x0000000000000103 r11: 0x00000000000c188f
r12: 0x00007fff9ca07110 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x000060000014db50
rip: 0x0000000104c30773 rfl: 0x0000000000010202 cr2: 0x0000000104c3070f

Logical CPU: 1
Error Code: 0x00000000
Trap Number: 6

Binary Images:
0x103a05000 - 0x103a0cff7 +org.cellprofiler.CellProfiler (3.0.0) /Applications/CellProfiler.app/Contents/MacOS/cp
0x104c0f000 - 0x104d08fe7 +Python (0) /Applications/CellProfiler.app/Contents/MacOS/Python
0x108852000 - 0x10888fdc7 dyld (433.5) <322C06B7-8878-311D-888C-C8FD2CA96FF3> /usr/lib/dyld
0x7fff9249f000 - 0x7fff924a0ffb libSystem.B.dylib (1238.60.2) /usr/lib/libSystem.B.dylib
0x7fff92652000 - 0x7fff926a8ff7 libc++.1.dylib (307.5) <0B43BB5D-E6EB-3464-8DE9-B41AC8ED9D1C> /usr/lib/libc++.1.dylib
0x7fff926a9000 - 0x7fff926d3fff libc++abi.dylib (307.3) <30199352-88BF-30BD-8CFF-2A4FBE247523> /usr/lib/libc++abi.dylib
0x7fff931c6000 - 0x7fff9359bbc7 libobjc.A.dylib (709) <54CD8D1A-5C98-3559-B13A-932B3D3DD338> /usr/lib/libobjc.A.dylib
0x7fff939c0000 - 0x7fff939d1ff3 libz.1.dylib (67) <46E3FFA2-4328-327A-8D34-A03E20BFFB8E> /usr/lib/libz.1.dylib
0x7fff939e0000 - 0x7fff939e4ff7 libcache.dylib (79) <093A4DAB-8385-3D47-A350-E20CB7CCF7BF> /usr/lib/system/libcache.dylib
0x7fff939e5000 - 0x7fff939effff libcommonCrypto.dylib (60092.50.5) <8A64D1B0-C70E-385C-92F0-E669079FDA90> /usr/lib/system/libcommonCrypto.dylib
0x7fff939f0000 - 0x7fff939f7fff libcompiler_rt.dylib (62) <55D47421-772A-32AB-B529-1A46C2F43B4D> /usr/lib/system/libcompiler_rt.dylib
0x7fff939f8000 - 0x7fff93a00fff libcopyfile.dylib (138) <819BEA3C-DF11-3E3D-A1A1-5A51C5BF1961> /usr/lib/system/libcopyfile.dylib
0x7fff93a01000 - 0x7fff93a84fdf libcorecrypto.dylib (442.50.19) <65D7165E-2E71-335D-A2D6-33F78E2DF0C1> /usr/lib/system/libcorecrypto.dylib
0x7fff93a85000 - 0x7fff93ab6fff libdispatch.dylib (703.50.37) <6582BAD6-ED27-3B30-B620-90B1C5A4AE3C> /usr/lib/system/libdispatch.dylib
0x7fff93ab7000 - 0x7fff93abcffb libdyld.dylib (433.5) /usr/lib/system/libdyld.dylib
0x7fff93abd000 - 0x7fff93abdffb libkeymgr.dylib (28) <7AA011A9-DC21-3488-BF73-3B5B14D1FDD6> /usr/lib/system/libkeymgr.dylib
0x7fff93acb000 - 0x7fff93acbfff liblaunch.dylib (972.60.2) /usr/lib/system/liblaunch.dylib
0x7fff93acc000 - 0x7fff93ad1ff3 libmacho.dylib (898) <17D5D855-F6C3-3B04-B680-E9BF02EF8AED> /usr/lib/system/libmacho.dylib
0x7fff93ad2000 - 0x7fff93ad4ff3 libquarantine.dylib (85.50.1) <12448CC2-378E-35F3-BE33-9DC395A5B970> /usr/lib/system/libquarantine.dylib
0x7fff93ad5000 - 0x7fff93ad6ffb libremovefile.dylib (45) <38D4CB9C-10CD-30D3-8B7B-A515EC75FE85> /usr/lib/system/libremovefile.dylib
0x7fff93ad7000 - 0x7fff93aefff7 libsystem_asl.dylib (349.50.5) <096E4228-3B7C-30A6-8B13-EC909A64499A> /usr/lib/system/libsystem_asl.dylib
0x7fff93af0000 - 0x7fff93af0ff7 libsystem_blocks.dylib (67) <10DC5404-73AB-35B3-A277-A8AFECB476EB> /usr/lib/system/libsystem_blocks.dylib
0x7fff93af1000 - 0x7fff93b7efef libsystem_c.dylib (1158.50.2) /usr/lib/system/libsystem_c.dylib
0x7fff93b7f000 - 0x7fff93b82ffb libsystem_configuration.dylib (888.60.2) /usr/lib/system/libsystem_configuration.dylib
0x7fff93b83000 - 0x7fff93b86fff libsystem_coreservices.dylib (41.4) <7D26DE79-B424-3450-85E1-F7FAB32714AB> /usr/lib/system/libsystem_coreservices.dylib
0x7fff93b87000 - 0x7fff93b9ffff libsystem_coretls.dylib (121.50.4) /usr/lib/system/libsystem_coretls.dylib
0x7fff93ba0000 - 0x7fff93ba6fff libsystem_dnssd.dylib (765.50.9) /usr/lib/system/libsystem_dnssd.dylib
0x7fff93ba7000 - 0x7fff93bd0ff7 libsystem_info.dylib (503.50.4) <611DB84C-BF70-3F92-8702-B9F28A900920> /usr/lib/system/libsystem_info.dylib
0x7fff93bd1000 - 0x7fff93bf3ff7 libsystem_kernel.dylib (3789.60.24) <6E9E485F-91F6-36B7-A125-AE91DC978BCC> /usr/lib/system/libsystem_kernel.dylib
0x7fff93bf4000 - 0x7fff93c3bfe7 libsystem_m.dylib (3121.6) <86D499B5-BBDC-3D3B-8A4E-97AE8E6672A4> /usr/lib/system/libsystem_m.dylib
0x7fff93c3c000 - 0x7fff93c5aff7 libsystem_malloc.dylib (116.50.8) /usr/lib/system/libsystem_malloc.dylib
0x7fff93c5b000 - 0x7fff93cb4ffb libsystem_network.dylib (856.60.1) <369D0221-56CA-3C3E-9EDE-94B41CAE77B7> /usr/lib/system/libsystem_network.dylib
0x7fff93cb5000 - 0x7fff93cbeff3 libsystem_networkextension.dylib (563.60.2) /usr/lib/system/libsystem_networkextension.dylib
0x7fff93cbf000 - 0x7fff93cc8ff3 libsystem_notify.dylib (165.20.1) /usr/lib/system/libsystem_notify.dylib
0x7fff93cc9000 - 0x7fff93cd1fe7 libsystem_platform.dylib (126.50.8) <897462FD-B318-321B-A554-E61982630F7E> /usr/lib/system/libsystem_platform.dylib
0x7fff93cd2000 - 0x7fff93cdcff7 libsystem_pthread.dylib (218.60.3) /usr/lib/system/libsystem_pthread.dylib
0x7fff93cdd000 - 0x7fff93ce0ff7 libsystem_sandbox.dylib (592.60.1) /usr/lib/system/libsystem_sandbox.dylib
0x7fff93ce1000 - 0x7fff93ce2ff3 libsystem_secinit.dylib (24.50.4) /usr/lib/system/libsystem_secinit.dylib
0x7fff93ce3000 - 0x7fff93ceaffb libsystem_symptoms.dylib (532.50.47) <3390E07C-C1CE-348F-ADBD-2C5440B45EAA> /usr/lib/system/libsystem_symptoms.dylib
0x7fff93ceb000 - 0x7fff93cfeff7 libsystem_trace.dylib (518.60.2) <6B145B10-5874-3E89-90CD-D370DB475BA1> /usr/lib/system/libsystem_trace.dylib
0x7fff93cff000 - 0x7fff93d04ffb libunwind.dylib (35.3) <3D50D8A8-C460-334D-A519-2DA841102C6B> /usr/lib/system/libunwind.dylib
0x7fff93d05000 - 0x7fff93d2eff7 libxpc.dylib (972.60.2) <1C9AF716-69DF-359F-85E9-7DFDE362F9A2> /usr/lib/system/libxpc.dylib

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 48075
thread_create: 0
thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=141.4M resident=0K(0%) swapped_out_or_unallocated=141.4M(100%)
Writable regions: Total=19.8M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=19.8M(100%)

                            VIRTUAL   REGION 

REGION TYPE SIZE COUNT (non-coalesced)
=========== ======= =======
Kernel Alloc Once 8K 2
MALLOC 11.2M 11
MALLOC guard page 16K 4
Stack 8192K 2
__DATA 1832K 46
__LINKEDIT 132.5M 5
__TEXT 9144K 43
shared memory 8K 3
=========== ======= =======
TOTAL 218.7M 110

Model: MacBookAir5,1, BootROM MBA51.00EF.B0C, 2 processors, Intel Core i7, 2 GHz, 8 GB, SMC 2.4f19
Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x802C, 0x384B54463531323634485A2D314736443120
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x802C, 0x384B54463531323634485A2D314736443120
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xE9), Broadcom BCM43xx 1.0 (
Bluetooth: Version 5.0.4f18, 3 services, 27 devices, 1 incoming serial ports
Network Service: iPhone, Ethernet, en4
Serial ATA Device: APPLE SSD SM512E, 500.28 GB
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: FaceTime HD Camera (Built-in)
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: Hub
USB Device: Apple Internal Keyboard / Trackpad
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: USB 3.0 Bus
USB Device: iPhone
USB Device: Composite Device
Thunderbolt Bus: MacBook Air, Apple Inc., 23.4

And here is the terminal output
[11458] PyInstaller Bootloader 3.x
[11458] LOADER: executable is /Applications/CellProfiler.app/Contents/MacOS/cp
[11458] LOADER: homepath is /Applications/CellProfiler.app/Contents/MacOS
[11458] LOADER: archivename is /Applications/CellProfiler.app/Contents/MacOS/cp
[11458] LOADER: /Applications/CellProfiler.app/Contents/MacOS/cp contains a digital signature
[11458] LOADER: No need to extract files to run; setting extractionpath to homepath
[11458] LOADER: Already in the child - running user’s code.
[11458] LOADER: Python library: /Applications/CellProfiler.app/Contents/MacOS/Python
[11458] LOADER: Loaded functions from Python library.
[11458] LOADER: Manipulating environment (sys.path, sys.prefix)
[11458] LOADER: sys.prefix is /Applications/CellProfiler.app/Contents/MacOS
[11458] LOADER: Setting runtime options
[11458] LOADER: Initializing python
Illegal instruction: 4

Hope this helps.


Same problem here with MacOS 10.11.6


Hi guys,

We just realized the initial release version we put up was 10.13 only; 10.12 should be coming soon (I think by end of the day today). We’re working on finding a 10.11 machine to build 3.0.0 on, but I’m less clear on the timeline for that.


@MarcKobudo A new version is available now:


If someone has access to a machine running macOS 10.11 and wants to help out, let me know. :slight_smile:


This version started up for me on 10.12.

One issue it has is the “Could not find pipeline file: sn_0_6727274” problem, but clicking ok makes that go away.

Running the welcome screen pipeline yields this:

Error while processing NamesAndTypes:
(Worker) URLError: <urlopen error [Errno 8] nodename nor servname provided, or not known>
Do you want to stop processing?

I wonder if it’s because in Images it is looking for the images here:
(assuming I typed that correctly, it yields a 404 error if I just put it in a web browser - oh, wait, if I add the actual image name to the end, like 01_POS002_D.TIF then it actually loads the image just fine)

Hope this helps diagnose!


Interesting. Unfortunately, I can’t reproduce. Are you using a VPN or some other proxy?


Orc5 is working in my 10.11.6 now after installing wxpython


@allen_goodman Nope, no VPN. Hm, it works now. Very strange.

LMK when the version at cellprofiler.org/releases is the ‘final’ version and I can test again from there just to be sure.


@Anne_Carpenter If you have time, you should try the current release.


Not sure if this helps but I get the below error hen I try to run:

Terjes-MacBook-Pro-2:Resources terjegloerstad$ ~/Desktop/CellProfiler.app/Contents/MacOS/CellProfiler
Traceback (most recent call last):
File “CellProfiler.py”, line 8, in
File “cellprofiler/main.py”, line 136, in main
File “/private/var/folders/_3/nmjl0qjn3bl6bp9qdll84tc18fpk6c/T/pip-build-SPZ6VW/pyinstaller/PyInstaller/loader/pyimod03_importers.py”, line 396, in load_module
File “cellprofiler/gui/app.py”, line 12, in
File “/private/var/folders/_3/nmjl0qjn3bl6bp9qdll84tc18fpk6c/T/pip-build-SPZ6VW/pyinstaller/PyInstaller/loader/pyimod03_importers.py”, line 396, in load_module
File “wx-3.0-osx_cocoa/wx/init.py”, line 45, in
File “/private/var/folders/_3/nmjl0qjn3bl6bp9qdll84tc18fpk6c/T/pip-build-SPZ6VW/pyinstaller/PyInstaller/loader/pyimod03_importers.py”, line 396, in load_module
File “wx-3.0-osx_cocoa/wx/_core.py”, line 4, in
File “/private/var/folders/_3/nmjl0qjn3bl6bp9qdll84tc18fpk6c/T/pip-build-SPZ6VW/pyinstaller/PyInstaller/loader/pyimod03_importers.py”, line 687, in load_module
ImportError: dlopen(/var/folders/wx/xnb00vvd0n9db8714wlx9mnr0000gn/T/_MEInORt08/wx.core.so, 2): Library not loaded: @loader_path/libwx_osx_cocoau_xrc-3.0.dylib
Referenced from: /var/folders/wx/xnb00vvd0n9db8714wlx9mnr0000gn/T/_MEInORt08/wx.core.so
Reason: image not found
[1077] Failed to execute script CellProfiler


Thanks. This really helps. I am on 10.11 and Cell profiler 3 keeps on crashing while starting. Looking forward to the support for 10.11