CellProfiler 2.1.1 MacOSX El Capitan

Hi there, I just swith to Mac OSX EL Capitan and now I´m not able to start Cell Profiler, any suggestion?

Thanks a lot in advance


What happens when you start? Any errors?

You can try clearing your config files: viewtopic.php?f=14&t=806#p6248
Or you can try a newer “trunk build” cellprofiler.org/cgi-bin/trunk_build.cgi

We are working on a new release of the Fall and I know that one of our developers has El Capitan, so let’s cross our fingers for a better solution soon.


I am having the same issue. The message that appears is that I need to download the legacy Java SE 6 to run CellProfiler. I was using JDK 8 and also tried with Java SE 8, but neither worked. When I reinstalled Java SE 6, CellProfiler started again.
Any updates on whether CellProfiler will be compatible with Java 8? Or is this a Mac OS X problem? I know that the new OS is having some issues with Java, but not sure what the solution would be. Thanks for your help!


Hi Andrés,

From one of our developers:

[quote]If the user is open to using master, master has Java SE 8 support. If not, they’ll need to wait for the release.

The most recent instructions for getting the master branch to build are here: github.com/CellProfiler/CellPro … stallation

Hope that helps!

Hi David,

Thanks for your reply. For some reason I missed the notification for your reply, so I’m really sorry about the late reply. I’ve been using CellProfiler for a while with the legacy SE 6, but I wanted to follow up about this issue. I tried installing the latest trunk build from github as recommended, but now CellProfiler crashes entirely. I am attaching the log that was saved from Terminal.
Thanks for your help!
CellProfiler_CrashReport.txt (57.4 KB)

Hi Andrés,

If you mean the trunk build from http://cellprofiler.org/releases/ then yes, I think that does NOT work on El Capitan. But if you are willing to build this from source yourself, as documented here then it should work on El Capitan. Is that what you tried?

Hi there,

I am experiencing similar problems after updating to El Capitan and was wondering if there are any plans to release a stable version that works for this OS? I tried using the master version from Github, which at least starts, but gives me the attached error and seems to have some glitches (e.g. EditManualSegmentation crashes after a few cells have been segmented).

Thanks for your help!

Uploading…error.txt (7.7 KB)

Hi @Bombyx,

You can try this fairly recent Mac build here: www.broadinstitute.org/~dlogan/CP_executables/CellProfiler_2.1.2_20160112_Mac.dmg
We will be making this trunk build more readily available soon. I don’t have El Capitan yet myself (Broad IT restrictions here), but we have tested on it and it should work. Please let us know of any bug reports!

But the errors you see are mostly all innocuous

  • Plugins directory - you can change this (and I believe this is better configured now)
  • The java errors might be an issue - what Java do you have installed?
  • vigra warnings are for an unimplemented (as yet) module

Let us know how it goes.

Hi David,

it works in general (or at least starts), but seems to have a problem with the EditObjectsManually (or more specifically crashes and freezes when I try to split objects). I had problems with this plug-in before. It crashed when I tried to save the edited objects as image (CellProfiler just crashed), but I am not sure if the problem is related.

Thanks for your help.


Only yesterday I update the MAc system to El Capitan, and now Cell Profiler (2,1,1) does not work. How can I obtain the version 2.1.2, which seems to work? (The url above is not working for me).

Thank you in advance

First I would say to update the Java Run Environment and the Java Development Kit- you’re going to need those to run any updated versions of CP anyway. If your current copy of CP doesn’t work after updating those, you can download CP 2.2.0 here. 2.1.2 probably does not exist as a build anywhere anymore, but 2.2.0 should work for you.