CellProfiler 2.1.0 does not startup

I am sorry, but I was running new CP version on win64.
However I dont have a clue what happened, but startup of CP is fast as it shuts down.
Just seen black screen and logo of CP for 1 second. Then program disappears.

I tried to reinstall, tried to install the trunk… Nothing help.
Older version run alright.

Do you have some advise, please?
Thank you very much.
Best wishes

Hi Josef,
An initial question: What OS are you running from? Windows, Mac or other?

Hi Mark,
Windows 7, 64bit. SP1
4CPU. i3-2105 CPU @ 3.1GHz, 4GB RAM.

Thank you for reply and sorry for incomplete description.

Can you give a try running CP 2.1 from the command line a try? Follow these instructions:

  • Start a command line window; see here
    for how to do this. - From the command prompt, type cd "c:\program files\CellProfiler"assuming you installed it in the default location.
  • Type cellprofiler.exeto start the program.

If CP quits suddenly, it should output any error messages to the command window. If so, could you copy-and-paste the messages in the reply to this thread? (As an aside, you should either un-install CP 2.0 first before installing 2.1 to be on the safe side, or install 2.1 to a different folder)

Dear Mark,
here it is…

Microsoft Windows [Verze 6.1.7601]

C:\Users\Jaroš>cd “c:\program files\CellProfiler”

c:\Program Files\CellProfiler>cellprofiler.exe
Traceback (most recent call last):
File “cellprofiler\utilities\jutil.pyc”, line 311, in start_thread
File “javabridge.pyx”, line 537, in javabridge.JB_VM.create (javabridge.c:3796
UnicodeEncodeError: ‘ascii’ codec can’t encode character u’\u0161’ in position 7
061: ordinal not in range(128)
Failed to create Java VM
Uncaught exception in CellProfiler.py
Traceback (most recent call last):
File “CellProfiler.py”, line 168, in main
File “cellprofiler\cellprofilerapp.pyc”, line 37, in init
File “wx_core.pyc”, line 7978, in init
File “wx_core.pyc”, line 7552, in BootstrapApp
File “cellprofiler\cellprofilerapp.pyc”, line 67, in OnInit
File “cellprofiler\gui\cpframe.pyc”, line 26, in
File "cellprofiler\modules_init
.pyc", line 21, in
File “cellprofiler\cpmodule.pyc”, line 28, in
File “cellprofiler\pipeline.pyc”, line 59, in
File “bioformats_init_.pyc”, line 187, in
File “bioformats_init_.pyc”, line 157, in start_cellprofiler_jvm
File “cellprofiler\utilities\jutil.pyc”, line 362, in start_vm
RuntimeError: Failed to start Java VM
Load ilastik Core
stopping worker thread 0
stopping worker thread 1
stopping worker thread 2
stopping worker thread 3
stopping worker thread 4

c:\Program Files\CellProfiler>

I checked also the Java and it looks it works fine. Im using the Oracle Java, but no problem to change it.
Unistalling all versions and installing the new one I did. No change.

I also tried to reinstall of Java. It didnt help… /: (Java 8 - Oracle)

Hi Josef,

It looks like a Unicode/non-English character issue, possibly in your preferences or your Default Input/Output Directories. Take a look at this FAQ for a possible fix.


Dear David and Mark,
solved. Even deleting of default pathways in registers didnt help. Probably creation of Java VM was somewhere in different folder of username with diacritics. So I created new profile/account without diacritics and everything works!

Thank you very much.
Best wishes.

1 Like

OK, glad it was solved at least!

I just spent some time solving this issue on my computer - same case - ascii non-compatible characters in username of windows. Unfortunately, I found this thread after all the effort. Could you fix this bug? This is 3 years old thread and the bug is still there…


I’m sure you will appreciate that we do not have a huge team of software engineers supporting this free software.

We do welcome pull requests that fix bugs - one for this would be most welcome.