CellProf CP_Beta_win (on Linux SunVM ) NOW working!

Hello,
I tried to run CellProfiler Beta for windows, on a Linux machine (Ubuntu 9.04, 64 bits) using either Wine, or Sun virtual machine.
No success !
some suggestions ? (by the way in the case it would be made to work, that would be an easy entry path for linux users interested to try/evaluate CellProfiler)

addendum:
I have Python 2.6, numpy, biopython installed on this ubuntu system.
Is the install of the CellProfiler beta version for linux easily done at this point (without too much tweeking and command_line) ?

Hi,
We have never tried this one Wine, to my knowledge. A few questions:
Did the install go smoothly?
Does CP not even launch?
Please copy and paste any terminal output here.

Just curious - Did CP ever work on Wine?

We’re still working on the Linux standalone release, and may be your best bet going forward.

Best,
David

We have never tried this one Wine, to my knowledge. A few questions:
Did the install go smoothly?
Does CP not even launch?
The install went first smoothly (just right clicking on the exe, and specify “open with Wine”.
Then however it displays a white rectangle (possibly at the time of the command window display), and hangs-up. There is no terminal window, and hence no messages.

Just curious - Did CP ever work on Wine?
I do not know


Otherwise, I got closer to the mark using Sun VirtualBox 3.0 (free download, running on Ubuntu 9.04 64 bits).
When trying a win2K virtual machine, it loads, displays the terminal, and then win2K displays an error about a missing dll (gdiplus.dll); I did not work this further at this point.

On a WinXP-pro virtual machine, the terminal displays, the CellProfiler windows displays.
There are errors displayed on the terminal: (I could nor copy/paste the text; instead, I took a picture snapshot of the screen, and did OCR on the captured image. There are mistakes below, for example the “m” appear to be understood as “n”, eg “module” is recognized as “nodule”; also, the left part is somewhat truncated

-CellProfiler
traceback (nost recent call last): File “cellprofilerSnodulesSloadimages.pyc”, line 58, in
File “biofornatsS init .pyc”, line 7, in
File “cellprofiler\utilities\jutil.pijc”, line 35, in
File “cellprofilerSutilitiesSsetup.çyc”, line 103, in findjavahone
iJ in do us Error: [Error 21 Le fichier spucifiû est introuvable
rraceback <nost recent call last):
File “cellprofilerSnodulesS init -pyc”, line 257, in add_nodule
File “cellprofilerSnodulesSsaveimages.pyc”, line 37, in
File “biofornatsS init .pyc”, line 7, in
File “cellprofilerSutilitiesSjutil.pyc”, line 35, in
File “cellprofilerSutilitiesSsetup.çyc”, line 103, in findjavahone
^JindousError: [Error 21 Le fichier spucifiû est introuvable
lone
lould not load these nodules [('cellprofiler.nodules.saveinages1, UindousError(2
, JLe fichier sp\xe9cifi\xe9 est introuvable1))]
lubversion revision: 9722


By the way, would there be a way to upload the captured image directly to the site, so that you can see exactly what I got or a better solution would be send you the image by e-mail
{could you directly e-mail me the right e-mail address, so that it does not get displayed openly to pishing?}

Hi,

You can report errors directly to us with CP2 using the “Send Report…” button on the error dialog. Or copy/paste the displayed text. However, if that doesn’t work, you can upload an image/screenshot on the Forum here using the “Upload attachment” tab, located below the input window.

You also need to have Java (JRE) installed to run CP2. Do you? 64-bit?

We will have a new Windows Beta up soon, which should work for Win x64.

David

Hello David,

here is the ouput I got when trying to install CellProfiler (win32 beta) on Sun VirtualBox (under Ubuntu 9.04, 64 bits).
I tried both a winXP-pro virtual machine, and a win2K virtual machine.
the closest hit seems to be the winXP install assay; but there are error messages at this point on the terminal, about missing files.

Best,




You might have better luck with our newest beta build (v9777) from the website. There are two improvements which should work to your advantage: (1) you can choose between 32- and 64-bit builds; (2) the JRE is bundled with it, which should avoid the SaveImages error messages you’re seeing.

Regards,
-Mark

Hello Mark,
you were right to the point.
I tried the new beta build (v9777) on a 32bits-XP-virtual machine (Sun VirtualBox) under Ubuntu 9.04 64 bits.
The install worked, and I could run the yeast example down to completion ! :smiley:
best,

note: As before, I suppressed all window displays for all pipeline steps, exept for the 4 last ones (various displays of results). (This avoids memory problems).


Great, glad Mark’s suggestion of the new build worked. Just as followup, for anybody else reading this, it was likely the lack of Java (JRE) that was causing the earlier trouble.

And also note that some of the memory error problems should be eased with some recent updates as well.

Cheers,
David