Cellpose GUI not popping up on Mac OS Mojave 10.14.6

I installed Cellpose in its own environment on anaconda as outlined on the github page. I am able to use it when running Jupyter notebooks, but when I run python -m cellpose in terminal, I get the following message: “Class RunLoopModeTracker is implemented in both /opt/anaconda3/envs/cellpose/lib/python3.7/site-packages/cv2/.dylibs/QtCore (0x1a1f85d7f0) and /opt/anaconda3/envs/cellpose/lib/libQt5Core.5.dylib (0x1a2837ca80). One of the two will be used. Which one is undefined.”

Along with this message, an empty window pops up instead of the GUI and nothing shows up even when I drag an image, as shown in the attached screenshot.

I am running python 3.7.0 and cv2 version 4.2.0 on MacOS Mojave 10.14.6. Would this issue be solved by downgrading cv2? Any suggestions?

Thank you.

Hi, as this is a direct bug for Cellpose, perhaps this post would have a better place in their GitHub issues page?
I do not see cellpose as a direct community partner here so perhaps they are not so active here.

Sorry I could not be of more help

Oli

Good idea! Thanks, I didn’t see the GitHub issues page before.