Cell profiler not working after Mac OS X Java update



Dear CellProfiler,

Can anybody help? I use the previous version of Cell profiler for Intel Mac’s (I note you uploaded a new version on Sept 22nd - this problem also applies to that release). Yesterday my Mac OS X Leopard system advised me to install Apple’s latest update - a new release of JAVA. Since then, when I open Cell profiler I can no longer type any text into boxes (e.g. change the default filename) yet the rest of the program seems to work fine).

The following appears on loadup in terminal:
Last login: Fri Sep 26 15:17:56 on ttys000
jr-mac7:~ richardreschen$ /Users/richardreschen/Desktop/MACI_1.0.5122/CellProfiler.command ; exit;
name /Users/richardreschen/Desktop/MACI_1.0.5122/CellProfiler.command
Fri Sep 26 15:18:32 jr-mac7.gurdon.cam.ac.uk CellProfiler[777] : CGContextGetBaseCTM: invalid context
Fri Sep 26 15:18:32 jr-mac7.gurdon.cam.ac.uk CellProfiler[777] : CGContextConvertSizeToDeviceSpace: invalid context
Fri Sep 26 15:18:32 jr-mac7.gurdon.cam.ac.uk CellProfiler[777] : CGContextConvertSizeToUserSpace: invalid context
Warning: latest version of matlab app-defaults file not found.
Contact your system administrator to have this file installed
Multi-threaded Math Library is found.
Setting number of computational threads to 1.
Registered Multi-core features.

(Note it has always said Warning: latest version of matlab app-defaults file not found.) The new version of Cell Profiler doe snot work either, this one does not even get past terminal and the messages are: Last login: Fri Sep 26 16:18:48 on ttys003
jr-mac7:~ richardreschen$ /Users/richardreschen/Desktop/untitled\ folder/CellProfiler.command ; exit;
name /Users/richardreschen/Desktop/untitled folder/CellProfiler.command
/Users/richardreschen/Desktop/untitled folder/CellProfiler.command: line 11: /Users/richardreschen/Desktop/untitled: No such file or directory

[Process completed]

I don’t know anything about JAVA or programming so the above messages don;t meant anything to me. However I use Cell Profiler to calculate mitotic indexes for a series of experiments I am doing, and need it desperately to work! Can anyone help?

Many thanks
Richard Reschen

Can't modify text fields

The newest version of CP is not working because of the space in “untitled folder”, where you’ve installed it. If you rename it to “untitled_folder”, it should fix that issue. I do not know if the latest version improves the Java behavior or not. Please let us know, and we’ll investigate it here, as well.

Ray Jones


Hi Richard,

We just added this warning to our downloads page:

“Apple has recently (2008_09_24) released “Java for Mac OS X 10.5 Update 2”. We highly recommend you do not install this! This Java update renders text boxes to be uneditable in the compiled version of CellProfiler. This occurs in both 10.4 and 10.5 (Tiger and Leopard).”

So if you have installed this update, it is apparently practically impossible to undo the Java update without re-installing the OS(!), according to Apple (I can’t find the link right now). While this is not a great solution, we can provide you with the 1.5.0 Java frameworks that doesn’t have this bug. It worked for one of our Macs here, but note, this may void your Apple warranty:
Download Java 1.5.0 from cellprofiler.org/linked_files/Java1p5.tar.gz and untar it into /System/Library/Frameworks/JavaVM.framework/Versions/ with these commands:

cd /System/Library/Frameworks/JavaVM.framework/Versions/
tar xvfz Java1p5.tar.gz

Hopefully, Mathworks will get a fix for this soon. We have submitted a bug report with them, re: deployed applications.


Hi Ray and David,

Thanks for your quick replies. I am at a conference until friday so will try out these fixes when I get back on Friday.

Best wishes

Richard Reschen

PS CP is a great program!


Dear both,

Sorry for my late reply. I have successfully installed the new version of Cell Profiler (thanks for the tip about spaces in directory names), and that has the same problem (can’t type text in fields). I think rather than try and load the old java on my machine I will try and use Cell Profiler on an older machine without the update until a fix comes out, as I don’t want to risk anything on this one.

Best wishes




The Mathworks has offered this suggestion, for those of you using TimeMachine:

  1. In the Finder, go to directory [Computer_Name]/MacIntosh HD/System/Library/FrameWorks
  2. Start Time Machine, and restore the following directories to a date preceding the upgrade:

We’ll let you know if we have any other fixes/workarounds.



Is there any update or workaround for this issue? Would using the “developer version” in MatLab solve this problem? Thanks for any help.



Yes, using the developer’s version solves this problem. Matlab still has some bugs with the updated Java, but CellProfiler will work as usual.



Hi all,

Over the weekend I noticed a Mac OS X Java Update 3. It was only small, about 30MBs… I didn’t install it, and it seems to require prior installation of Java Update 2.
Does anyone know if this is the required fix for the input problem in CP?

Cheers, Tim


Hi all,

I just updated my 10.5.6 MacBook Pro with the Java for Mac OS X 10.5 Update 3 and the Compiled 5811 Bugfix works. So it looks as though this latest update has solved the problem.

It would be appreciated if you report your results either way.



I’m very new to Cell Profiler and have encountered the Java problem mentioned above. I’m running a PowerPC G5 MacPro with Mac OSX 10.5.6 and the latest Java version, I think. I have installed the following version of Cell Profiler:


but the text fields are not editable. Any help would be appreciated about where I can find my Java version, install the correct version and correct the text field error.

Many thanks,



Hi Barry,

Though we have not tested the Java update on our PPC- and our PPC runs Tiger, so I don’t believe its an issue anyway- I would assume the same fix suggested in the above posts would apply: download the Java 1.5 from our website cellprofiler.org/download.htm (it’s listed under the Intel Mac version- we’ve never met anyone running Leopard on their PPC!) and replace the 1.5 in your Java frameworks folder (detailed directions are in the above posts).

Let us know how this turns out so we can direct other users accordingly.



Many thanks Kate,

I’m afraid I’ve got one or two more questions! Using the terminal commands mentioned further up the thread, I get the following errors:

endosome:Versions spiesslab$ tar xvfz Java1p5.tar.gz
tar (child): Java1p5.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors

I’ve had a look in the /System/Library/Frameworks/JavaVM.framework/Versions/ folder and there is quite a list, see the attached .png file! I’m confused as there is already a folder for 1.5.0? Apologies for the basic questions, I’m not used to rummaging around the computer’s inner files!



Hi Barry,

Yup, that is what the Java Frameworks folder looks like! You’re basically replacing the old 1.5.0 with the one we gave you- this will allow Cellprofiler to work again (the “1.5” folder is just an alias to the 1.5.0 folder).

To use the tar command you’ll need the Java1p5.tar.gz file to be in the directory you’re untarring it to unless you give the tar command the full path. Or, if you find it easier, drag the downloaded file to your desktop and use something like Stuffit Expander to expand the file, then copy the expanded 1.5.0 to your Java Frameworks folder (after you’ve gotten rid of the old 1.5.0).



Thanks Kate,

Deleted the old 1.5.0 folder and dragged the new one in. It still gives the same error messages when starting up but the text fields are now editable? I’m going to run an analysis overnight and see what happens!

Thanks again,




Its me again! After successfully getting cellprofiler to work following our last discussions, my mac decided to die in quite a dramatic fashion. I’ve just received my new intel mac pro and have set about installing cellprofiler again. But this time I do not have a javavm.frameworks folder in my frameworks folder in my library? Can I just creat one and pop the java 1.5.0 folder in there?

Thanks for any help,