Cell profiler fail to start

Hi,

I can’t start the software, I just see the cmd dialog running empty for a minute and then shuts down immediately after showing a quick massage.

any suggestions?

Hi @Daniel_Waiger,

Have you checked out the instructions on this page?

Hi, I have the same issue, have you fixed it?

Hi, I have checked all the instructions , but still does not work. any other suggestion?

Are you seeing an error message? You might want to try launching cellprofiler.exe from the command line if the window closes too quickly to see it. If you can post the error here we can provide further help.

It only shows this black window for about 10 seconds and quickly closed automatically. And I think I have set up the environmental variables and region correctly.

Any other suggestion?

Wei

Thanks, could you open up command prompt and navigate to C:\Program Files (x86)\CellProfiler, then type CellProfiler.exe. This should then try to open CellProfiler and will give you an output if something is going wrong.

You may also want to disable Beta Unicode support in Region Settings.

It seems work in my PC. Is this the correct interface of cellprofiler?

Yes, that’s exactly what it should be doing.

Hi, now checking, I’ll post an update later.

did everything according to the instructions, still having errors.

Hi @Daniel_Waiger,

It looks like your java paths are not set properly. Could you send a screenshot of your system environment variables? Since you’ve installed CellProfiler to an unusual location you’ll need to have CP_JAVA_HOME set to D:\Software\CellProfiler\java.

Thanks

image

still doesn’t work, I’m still getting an error.

@Daniel_Waiger Great, that’s a different issue now. This is happening because CellProfiler wasn’t installed to the C drive. If you go back into system environment variables and change “TMP” to a location somewhere on the D drive that should get it working.

There should be a better fix for this issue in CellProfiler 4.

so, it appears to be working from the icon, but not from the command line…

That’s promising. To get it to run from the command line may just require you to start the command from a folder on drive D, rather than being in C:\Users\Daniel.

I’m having the same issue, have gone through all the suggested fixes and the program still won’t start…

@Jasmine_Zeki Could you confirm the error message you see and send a copy of your environment variables?