Cell Profiler Analyst: Classifier fetches grey boxes instead of cell images

Previously I haven’t had a problem with classifying cells but recently classifier has begun to fetch grey boxes instead of the actual cell images and when I click on the images the following error message appears:

An error occurred in the program:
TypeError: ‘NoneType’ object is not subscriptable

Traceback (most recent call last):
File “imagetile.pyc”, line 118, in OnDClick
File “imagetools.pyc”, line 61, in ShowImage
File “imagetools.pyc”, line 51, in FetchImage
File “dbconnect.pyc”, line 672, in GetFullChannelPathsForImage
File “ntpath.pyc”, line 73, in join
File “ntpath.pyc”, line 57, in isabs
File “ntpath.pyc”, line 125, in splitdrive

My image data is stored on a campus wide X: drive, when I store a few files locally to test them this is not a problem. Have you got any advice?
Attached are my properties file and my pipeline. EDIT: I cant see how to attach these from here…

Could you solve the problem?
You can attach files using the upload button on the top bar of the messenger box.


Yes I solved the problem in the end, apparently if you put the “save images” module after the “export to database” module it confuses it (not sure why) so I solved the problem by just putting “save images” before export. Still confused but it works now.

1 Like

Ah yes! ExportToDatabase saves the paths to the images which CPA needs to access them, but only those images upstream of ExportToDatabase in the CP pipeline. So any SaveImages downstream won’t be included nor thus seen by CPA.