Care installation, CUDA 10.0 on Windows Server 2019

Hi,
I’m currently trying to install “CARE” training https://csbdeep.bioimagecomputing.com/ via “Careless” https://github.com/sommerc/careless.
I managed to do this before on a Windows 10 computer. Now I would like to run it on Windows Server 2019 but I would need CUDA <= 10.0 which is only available up to Windows Server 2016. So I tried CUDA 10.0 for 2016 but It didn’t work because Tensorflow was not found. Does anybody have an idea how to deal with these compatibility issues?

Hi there

I am sorry but that message is not very informative. You mean you managed to install CUDA toolkit 10.0 for Windows Server 2016 (and then managed to copy the CuDNN files into the folder?)

Now TensorFlow has nothing to do with your CUDA library installation. So if it is not found, there is probably an issue when you setup your conda environment… Please share any error messages or logs that could help make sense of the problem.

Best

Oli

1 Like

Hi Oli, thank you for the quick reply!

Yes, that’s what I did. I try to run the Jupyter notebook but I get the following error:


ModuleNotFoundError Traceback (most recent call last)
in
----> 1 from careless.care import care

~\Desktop\careless\careless\care\care.py in
10 warnings.filterwarnings(“ignore”)
11 os.environ[‘TF_CPP_MIN_LOG_LEVEL’] = ‘3’
—> 12 import tensorflow as tf
13 tf.compat.v1.logging.set_verbosity(tf.compat.v1.logging.ERROR)
14

ModuleNotFoundError: No module named ‘tensorflow’

I also tried to reinstall tensorflow gpu-1.13.1 via pip install and it’s already there.

I would suggest that you check which python is running in your virtual environment.

From Your Conda command line, activate your environement and type
where python

This should list the python in your current environment first (there could be others)

Then check where your Jupyter kernel is running from by typing
jupyter kernelspec list

If it’s not the right kernel (not the right location) then you need to debug this.

I found help in this thread

For your information, this is what it looks like on my PC when I run these commands

(base) C:\Users\oburri>conda activate d:\env-stardist

(d:\env-stardist) C:\Users\oburri>where python
d:\env-stardist\python.exe
C:\Program Files\Python37\python.exe
C:\Users\oburri\AppData\Local\Microsoft\WindowsApps\python.exe

(d:\env-stardist) C:\Users\oburri>jupyter kernelspec list
Available kernels:
  python3    d:\env-stardist\share\jupyter\kernels\python3

(d:\env-stardist) C:\Users\oburri>

To me it looks like python is in the correct place, my py36_careless environment:

(base) C:\>conda activate py36_careless

(py36_careless) C:\>where python
C:\Users\boadmin\.conda\envs\py36_careless\python.exe

(py36_careless) C:\>jupyter kernelspec list
Available kernels:
  python3    c:\users\boadmin\.conda\envs\py36_careless\share\jupyter\kernels\python3

The thread you provided also didn’t get me further. I tried sudo pip install --upgrade ipykernel and python3 -m ipykernel install --user but it didn’t even run.
Sorry, my python knowledge is very limited.