Can't Drag/Drop files to Fiji

Hi all, just updated Fiji after a couple of months of not updating. Running Fiji on macOS Sierra 10.12.3 with Java v8 update 131 (build1.8.0_131-b11). After updating Fiji can’t open files by drag/drop to Fiji in the Dock. Wouldn’t be such a big deal if Fiji would allow me to File > Open multiple files at once (which I haven’t found to be the case). Any suggestions? Thanks!

1 Like


That is weird. Helpful - eh?! :slight_smile: With all my recent updates - I have not come across this problem myself.

Honestly - if I were you - I would try completely uninstalling and reinstalling Fiji. When in doubt … this seems to be the ‘best’ fix in these cases.

eta :slight_smile:

1 Like

@climber12 I once had the same issue, but after restarting Fiji it worked again.

Else I would go with the solution of @etadobson :slight_smile:


Same, broken for me too.

Dear @climber12,

to clarify: you are trying to open multiple files by selecting them in Finder and drag&dropping them onto the ImageJ/Fiji window?


I had the same problem since yesterday "no more drag and drop opening function"
then yesterday it has started to work perfectly again :thinking::smiley:

This seems to be an issue with more recent versions of Java 8 on macOS. Instead of using a system JRE, could you (as in “anyone experiencing the issue”) check if the drag&drop works with the JRE that is bundled with Fiji? That has solved the issue for me…

For the interested: the issue has been fixed in OpenJDK but seems to never have made it to Oracle…


Simply, yes. When selecting a single file or multiple files from Finder and dragging to Fiji on the Dock, Fiji will open (if not already running), but files do not open.

Will check re: bundled JRE and get back to you.

Drag and dropping on the dock icon does not work for me either

Which operating system are you on @bryan_mcdonald? Does it work when you open Fiji and drag & drop onto the toolbar? Are you using the Java that is bundled with Fiji or another one (if so, which one)?

10.12.4 sierra

Won’t work from dock (either before or after program has launched) nor directly on the icon in the finder.

I have java version 8 update 131.

I can reproduce the inability to drag-and-drop onto the Fiji dock icon on macOS Sierra 10.12.5, with both Java 1.8.0_131 and Java 1.8.0_66 (the latter being the one currently bundled with new Fiji downloads).

As a workaround for now, you can drag-and-drop onto Fiji’s main window. You should see the status bar change to <<Drag and Drop>> while doing it.


After spending some time on the issue, it seems that our best chance to get drag&dropping files onto the Fiji/ImageJ (dock) icon back is a JEP that addresses platform specific features like handling events related to the macOS dock.

Sure. That will be far in the future, though, since it is for Java 9.

It is worth noting that this drag-and-drop issue has been discussed on the forum previously (and I had forgotten about it till I just found the thread again in a web search):

Thank you so much ctrueden, your workaround worked perfectly!

1 Like

Same problem, but files won’t open when double clicking on them in Finder. Just opens Fiji and stops.

The workaround ctrueden mentioned works well for opening multiple files though (I was going crazy trying to open 20 files individually each time to stitch them together!)

I am having this same problem now running Win10 64-bit. It seems to only be an issue on my personal laptop and not my desktop. I’ve scoured the forums at this point to no avail. Any suggestions to fix?


For those still reading this thread, I’m now running macOS 10.13.3, updated to ImageJ 2.0.0-rc-65/1.51u, and updated all Fiji libraries. The problem with drag/drop is fixed in every instance I’ve tried.

1 Like

@Wilson_Adams When you drag a file onto Fiji’s main window, does the status bar change to <<Drag and Drop>> as mentioned above? When you let go, does it trigger anything?

@ctrueden when i attempt to drag a file (a TIFF image in this case) into the status bar, my mouse cursor turns into a :no_entry_sign: symbol and will not respond to me ‘dropping’ the file. Nothing happens in the status bar when I drop the file, as far as I can tell