Can't Drag/Drop files to Fiji

Drag and dropping on the dock icon does not work for me either

Which operating system are you on @bryan_mcdonald? Does it work when you open Fiji and drag & drop onto the toolbar? Are you using the Java that is bundled with Fiji or another one (if so, which one)?

10.12.4 sierra

Won’t work from dock (either before or after program has launched) nor directly on the icon in the finder.

I have java version 8 update 131.

I can reproduce the inability to drag-and-drop onto the Fiji dock icon on macOS Sierra 10.12.5, with both Java 1.8.0_131 and Java 1.8.0_66 (the latter being the one currently bundled with new Fiji downloads).

As a workaround for now, you can drag-and-drop onto Fiji’s main window. You should see the status bar change to <<Drag and Drop>> while doing it.


After spending some time on the issue, it seems that our best chance to get drag&dropping files onto the Fiji/ImageJ (dock) icon back is a JEP that addresses platform specific features like handling events related to the macOS dock.

Sure. That will be far in the future, though, since it is for Java 9.

It is worth noting that this drag-and-drop issue has been discussed on the forum previously (and I had forgotten about it till I just found the thread again in a web search):

Thank you so much ctrueden, your workaround worked perfectly!

1 Like

Same problem, but files won’t open when double clicking on them in Finder. Just opens Fiji and stops.

The workaround ctrueden mentioned works well for opening multiple files though (I was going crazy trying to open 20 files individually each time to stitch them together!)

I am having this same problem now running Win10 64-bit. It seems to only be an issue on my personal laptop and not my desktop. I’ve scoured the forums at this point to no avail. Any suggestions to fix?


For those still reading this thread, I’m now running macOS 10.13.3, updated to ImageJ 2.0.0-rc-65/1.51u, and updated all Fiji libraries. The problem with drag/drop is fixed in every instance I’ve tried.

1 Like

@Wilson_Adams When you drag a file onto Fiji’s main window, does the status bar change to <<Drag and Drop>> as mentioned above? When you let go, does it trigger anything?

@ctrueden when i attempt to drag a file (a TIFF image in this case) into the status bar, my mouse cursor turns into a :no_entry_sign: symbol and will not respond to me ‘dropping’ the file. Nothing happens in the status bar when I drop the file, as far as I can tell

@Wilson_Adams What about if you run Plugins :arrow_forward: Bio-Formats :arrow_forward: Bio-Formats Plugins Shortcut Window and then drop the TIFF file onto that window? Does that work?

How did you fix it? I am running OS10.11.3 and just updated FIJI to 2.0.0-rc-65/1.51w and I cannot drag and drop my czi files. Prior to this it was working perfectly. I shoudl clarify - it is not that it doesn’r work but it takes about 10 minutes for it to open a flie instead of the less than minute it took before.

I’ve been told it has to do with the macOS Java and how it interacts with ImageJ/Fiji. Updating to macOS 10.13.3 and then updating Fiji is what fixed everything for me.

1 Like

Thanks I guess I will try that

Sorry for the delay in getting back. Unfortunately, the way i had to fix it was to do a full reinstall of FIJI. I had to install it into a folder without any admin permissions, and it seemed to do the trick.

Porting over all of the startup preferences is annoying. Starting to think about version control for my own personal version of FIJI to avoid the trouble in the future.

unfortunately this was not solving the problem. Ended up doing a full reinstall to fix the issue. Maybe something to do with admin permission on the install folder? not too sure. but I got it to work again.

Hi, I had this every time updated the software, drag & drop will just freeze, even task shows program is running.
I can’t reinstall it, as I have the mobile without installation

My solution below
After Update:
Close the program
Do not start from the shortcut
Go to the program folder
And create new shortcut

@Garorica Could you please follow these techniques to troubleshoot the freeze?

If you can generate a thread dump of the freeze, it would help us to understand what’s going on, and hopefully fix it.