Can't activate/restart Processor-0

Hello,

I have problems with the server Processor-0.
Here is my problem history:

  1. calling a script shows in the script GUI:

No Processor Available

The script service cannot find a processor to run this script ID: 3249662. You should contact your System Administrator.

  1. have a look omero admin diagnostics:
=====================================================
OMERO Diagnostics (admin) 5.6.2
======================================================

Server:     icegridnode                    running
Server:     Blitz-0                        active (pid = 191875, enabled)
Server:     DropBox                        inactive (disabled)
Server:     FileServer                     inactive (disabled)
Server:     Indexer-0                      active (pid = 191959, enabled)
Server:     MonitorServer                  inactive (disabled)
Server:     OMERO.Glacier2                 active (pid = 192035, enabled)
Server:     OMERO.IceStorm                 active (pid = 192036, enabled)
Server:     PixelData-0                    active (pid = 192044, enabled)
Server:     Processor-0                    inactive (disabled)
Server:     Tables-0                       inactive (disabled)
Server:     TestDropBox                    inactive (enabled)
  1. omero admin restart does not activate the Processor-0

  2. omero admin ice “server stop Processor-0” and omero admin ice “server start Processor-0” brings:

error: the server didn't start successfully:
The server is disabled.
  1. After omero admin stop all processes seems to be stopped and a restart of the server seems to be successfull - but the Processor-0 still doesn’t work. In Blitz-0.log there is an error after restart:
2020-07-08 11:40:32,867 ERROR [     ome.services.blitz.util.ParamsCache] (1-thread-4) Failed to load params for 2957988
omero.NoProcessorAvailable: null
        at ome.services.blitz.impl.SharedResourcesI.acquireProcessor(SharedResourcesI.java:444) ~[omero-blitz.jar:5.5.6]
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.8.0_252]
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[na:1.8.0_252]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[na:1.8.0_252]
        at java.lang.reflect.Method.invoke(Method.java:498) ~[na:1.8.0_252]
        at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:333) ~[spring-aop.jar:4.3.14.RELEASE]
        at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:190) ~[spring-aop.jar:4.3.14.RELEASE]
        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:157) ~[spring-aop.jar:4.3.14.RELEASE]
        at omero.cmd.CallContext.invoke(CallContext.java:85) ~[omero-blitz.jar:5.5.6]
        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179) ~[spring-aop.jar:4.3.14.RELEASE]
        at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:213) ~[spring-aop.jar:4.3.14.RELEASE]
        at com.sun.proxy.$Proxy84.acquireProcessor(Unknown Source) ~[na:na]
        at omero.grid.ParamsHelper.generateScriptParams(ParamsHelper.java:147) ~[omero-blitz.jar:5.5.6]
        at ome.services.blitz.util.ParamsCache$Loader.createParams(ParamsCache.java:304) ~[omero-blitz.jar:5.5.6]
        at ome.services.blitz.util.ParamsCache._load(ParamsCache.java:217) [omero-blitz.jar:5.5.6]
        at ome.services.blitz.util.ParamsCache.lookupAll(ParamsCache.java:181) [omero-blitz.jar:5.5.6]
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.8.0_252]
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[na:1.8.0_252]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[na:1.8.0_252]
        at java.lang.reflect.Method.invoke(Method.java:498) ~[na:1.8.0_252]
        at org.springframework.util.MethodInvoker.invoke(MethodInvoker.java:265) [spring-core.jar:4.3.22.RELEASE]
        at org.springframework.scheduling.quartz.MethodInvokingJobDetailFactoryBean$MethodInvokingJob.executeInternal(MethodInvokingJobDetailFactoryBean.java:257) [spring-context-support.jar:4.3.22.RELEASE]
        at org.springframework.scheduling.quartz.QuartzJobBean.execute(QuartzJobBean.java:75) [spring-context-support.jar:4.3.22.RELEASE]
        at org.quartz.core.JobRunShell.run(JobRunShell.java:202) [quartz.jar:na]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [na:1.8.0_252]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [na:1.8.0_252]
        at java.lang.Thread.run(Thread.java:748) [na:1.8.0_252]

I would be grateful for advice.

Best,
Susanne

I solved the problem:

restarting the omero server in another python environment was the reason for this problem.

1 Like