Cannot open timelapse multipoint multi-channel acquisition

I have an ND2 file that I took pictures of 14 points, with 3 channels (2 fluorescent, 1 brightfield), at 5 different time points. However, Bio-Formats does not recognize the various time points and does not even properly detect all of the series. I assume there should be 14 due to the 14 points, but only 11 is showing up. When I open the series, the data is just black for some reason…

I have played with the hyperstack parameters (including changing the stack order) and sometimes it is displaying the channels but still not the time data. I have played around with the chunkmap setting but that has not resolved anything.

Is this a known issue with any workaround?

Hi @iscienceluvr, i’m afraid this looks to be similar to other issues which we have seen recently with ND2 and we don’t have a fix in place yet (https://trello.com/c/LEjj3O3A/281-nd2-timepoints-incorrectly-detected-as-series). Have you updated to a new version of your acquisition software recently?

If you have a sample file showing this problem it would be very helpful for our testing, you can upload it to https://www.openmicroscopy.org/qa2/qa/upload/ if possible

Thanks for your response. I am not sure the version of the acquisition software (I am not in front of it right now), but if it’s not updated, it’s probably at most, like 3 years old. But I am not sure how that information is the most relevant here though. I am sure the data was properly stored in this ND2 file, as I can open it up with the NIS Elements Viewer, and the data is showing up perfectly fine. Interestingly though, that program will not let me export data, so hence I wanted to use ImageJ.

My file is about 22 GB and the upload limit is 2 GB in the link you have provided. Is there another way to send sample images?

@dgault Is there a known workaround for this? I would hope to have this issue fixed in the next couple days…
Also, if you want me to send an example file how should I send it as it is too big…

@iscienceluvr Im afraid at the moment there is no workaround and until we properly understand what is causing the problem it is realistically not going to be solved in the next few days. I will leave you a private message to arrange ftp details for transferring the larger file.

Hi, I know this is a 9 month old conversation, but I’m having the exact same issue. Is there a known workaround now? I thought it was just importing my images in the wrong order, which I could fix using a macro, but it seems that it’s not opening all of the time series similar to the issue the above user was having.

Any help would be very much appreciated!

Hi @kelseybettridge, we have had a number of different reports on this issue (see https://trello.com/c/LEjj3O3A/281-nd2-timepoints-incorrectly-detected-as-series) but thus far we do not have a fix or a work around. If you have any additional sample files which might help our testing you can upload them to https://www.openmicroscopy.org/qa2/qa/upload/