Cannot connect with OMERO.insight 5.5.17, but can connect with OMERO.insight 5.5.15

Hello,

Previously, I have been able to connect to our OMERO.server with OMERO.insight 5.5.17. On Friday I couldn’t, I received the error “Failed to log onto OMERO. Please check your username and/or password or try again later.” Looking at the omeroinsight.log it appears the password check is failing. However, if I use OMERO.insight 5.5.15 I am able to connect. I am using the same username and password in both cases. The only change I’m aware of since I was last able to use OMERO.insight 5.5.17 has been the OMERO.web upgrade to 5.9.1.

I am using linux and here is the omeroinsight.log file. The last entry is for 5.5.15 and the one before is 5.5.17 omeroinsight.zip (4.8 KB)

Thank you,
Laura

Hi @Laura190

The web upgrade should not affect the connection via OMERO.insight. No changes to the server were made.
Could it be an upgrade of your Java version?

Cheers

Jmarie

Thanks for your reply @j.burel

I was using openjdk 13, I have also tried openjdk 16 and java version 1.8.0_281, but I have the same issue.
We use LDAP, could that be a problem?

Thank you,
Laura

Hi @Laura190

We are not testing with non LTS java version.
Could you check for Java 1.8 the value of the property
jdk.tls.disabledAlgorithms in the file jre/lib/security/java.security to see if there is a value preventing you to connect?

Could you also check the version of openssl used?

I don’t think it is related to LDAP
Cheers
Jmarie

Thanks @J.burel,

For the property I have

jdk.tls.disabledAlgorithms=SSLv3, RC4, DES, MD5withRSA, DH keySize < 1024, \
    EC keySize < 224, 3DES_EDE_CBC, anon, NULL, \
    include jdk.disabled.namedCurves

and I am using OpenSSL 1.1.1j

Laura

Hi @Laura190

Could you try with Java 11? Several versions of Java 1.8 created, in the past, some issues.
Which OS is the server running on?

Cheers

Jmarie

Hi @Laura190

Could you also check if
omero-certificates · PyPI has been installed and configure where the OMERO server is running?

Cheers

Jmarie

Hello @j.burel

I have installed java version 11.0.10. The OS for the server is CentOS 7. omero-certificates is installed and configured where the OMERO server is running.

Still no luck connecting with omero.insight 5.5.17.

Thanks,
Laura

Hi @Laura190
Let me try to summarize the situation since I am running out of ideas:

  • you can connect via OMERO.web post upgrade to 5.9.1
  • you can connect using omero.insight 5.5.15 + Java version 1.8 or 11 post upgrade to 5.9.1
  • you cannot connect using omero.insight 5.5.17 + Java version 1.8 or 11 post upgrade to 5.9.1 but you were able prior to the upgrade.

Is that summary correct?

Hello @j.burel
Yes that looks correct.
Some other points, in case it’s relevant:

  • I upgraded to OMERO.web 5.9.0 first and then 5.9.1.
  • One of our users has the same thing using macOS (not sure which java version). I have also tried a Windows (Java 1.8) with the same behaviour.

Thanks,
Laura

1 Like

What is the version of the omero-server? 5.6.3?

Cheers
Jmarie

Yes, the server is 5.6.3

Laura