Cannot change the maximum RAM used by QuPath

Hi all,

after downloading the last QuPath version (0.2.0) I’m not able to change the RAM limit used by the software using the Help>Show setup. While my PC has 8 GB of RAM, QuPath detects current maximum capacity as 1.97 GB. It seems that the maximum memory is fixed to 2 GB and even decreasing it to 1 GB is not having any effect, upon restarting the software the max memory is still stuck at 2.
I have tried reinstalling Java and reinstalling QuPath but nothing seems to change.
Any idea?

Many thanks in advance for any help!
Dennis

Hmmm, this discussion might be relevant although the eventual solution seemed rather extreme: https://github.com/qupath/qupath/issues/321

It also links to a relevant older topic https://github.com/qupath/qupath/issues/175
Essentially, you should be able to edit the .cfg file in a plain text editor (e.g. Notepad, Atom).

You also shouldn’t need to install Java separately from QuPath, since it uses its own Java Runtime.

Thanks a lot, I have found only the first post that you sent me, but not the second, which solved the problem. Thank you very much.

1 Like