Can not open "czi"file by using metadata option



I want to open “czi” file in cellprofiler, it’s weird because sometimes I can extract different images by using metadata, but sometimes not. I use the same microscope, and same objectives. So can you tell me what is the problem? Thanks a lot.

The metadata columns Frame and C both seem to encode the channel. Do you have NamesAndTypes set to assign channels using those metadata? It is always beneficial to post your pipeline here for us to inspect.

Thank you for your reply. The worked pipeline is: extract data from metadata.cpproj (953.5 KB)

This pipeline, I can not extract metadata: can not extract metadata.cpproj (146.0 KB)

Both of these I use “Extract from image file headers”, Metadata data type: text. Pretty much all the same, I really can not understand why one works and the other not? Thanks a lot.

I have exactly the same problem as Flyhuxy. I have some .czi files from which metadata can’t be extracted. Has a solution been found?

Not certain, but you’d need to post a (zipped) czi file for us to test to be certain. There have been some czi-related bugfixes, but in general, you need to:

  • In Metadata, click the “Update metadata” button (NOT the “Update” button"), and this extracts info from the headers
  • Then view the metadata by clicking the Update button
  • Look at what columns vary, e.g. Frame and C in the example above
  • In NamesAndTypes assign channel names by the columns that varied across sites above

Post some examples if it still doesn’t work!