Can not launch CPA revision 10964 under Linux

I was able to run CPA developer version on both windows XP and a Linux cluster without any problem. However with recent updates of CPA, I can only run it on Windows XP, but not Linux any more. Here is the error message on the Linux system:

Traceback (most recent call last):
File “cpa.py”, line 74, in
from classifier import Classifier
File “/work/users/suntian/cpa/src/classifier.py”, line 679
<<<<<<< .mine
^
SyntaxError: invalid syntax

Here is some system information:
Linux 2.6.18-128.1.14.el5 #1 SMP Mon Jun 1 15:52:58 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

Does it look like a problem on our end? e.g. an incompatible python library etc…

Thanks,
Tianxiao

Hi Tianxiao,

The “<<<<< .mine” occurs in a file when svn updating encounters a conflict and can’t merge the needed changes (similar to that described here).

Unless you have made changes to the classifier.py that you need to retain, you should be able to delete classifier.py, and the associated .mine and .rXXXXX files in the folder (if any), and svn update again. This should restore the classifier.py file to working condition.

Regards,
-Mark

Hi Mark,

Your solution worked! Thanks a lot!

Tianxiao