Calculating multinucleated cells in muscle fibers


I was wondering if there was a way to calculate multiple nuclei in myotubes or multiple nuclei in any object for that matter. I saw a posting of it before but that was for Cellprofiler 1.0 and there was no good solution. Ideally I would like to be able to tell the number of nuclei per myotube but I don’t see a good way to do that. At least I would like to calculate the number of nuclei within myotubes as opposed to total nuclei. I get an accurate count of nuclei and pretty good myotube mask but I am having a little trouble counting the total nuclei in myotubes. I saw a previous post about it using UnifyObjects to merge myotubes and I do not see that module now.

Any help would be much appreciated.

I currently am using the
1.) CorrectIlluminationCalculate
2.) IdentifyPrimaryObjects(Nuclei)
3.) IdentifySecondaryObjects(Myotube,Nuclei as input,propagation,automatic, regularization 0.001)
4.) IdentifyTertiaryObjects(Myotube, Nuclei, named Cytoplasm)
5.) FilterObjects

I inlcuded some pictures and the pipeline I made
myotube_goodnuc.cpproj (98.4 KB)


This is still not a straightforward problem, since you can’t rely on the one-to-one mapping of nuclei to cytoplasm (myotube). I think the best solution is to reverse the normal method, namely:
(1) identify the myotubes as Primary objects.
(2) Totally independently also identify the nuclei as normal.
(3) Use RelateObjects to assign parent/child relationships to the myotube/nuclei, which in the process, counts the number of children (nuclei) per parent (myo)

I am attaching a pipeline I put together to get you started.

The problem is getting Step (1) above to be reliable. If the myotubes cross, identifying them is likely not to work well. One way to minimize this is with the EnhanceOrSuppress module with the “Neurites” setting. This “Tubeness” setting tends to depress the intensity of crossing, which I normally see as a ‘bug’, but in this case might be a ‘feature’! It will tend to break up the myotubes that cross, but there is no simple workaround for that. I added the DisplayHistogram just so you can see the results.

A couple other side notes:

  • Avoid JPG. This is a lossy image format and I can see artifacts when zoomed in.
  • The illumination correction is not really useful here, and may even be harmful. Check the intensity of the background of your raw images by mousing over them in CP – check in the center vs. the edge. I don’t see much need for it.
  • Are the Crop modules necessary?

myotube_goodnuc_DL.cppipe (15.1 KB)