Bug when saving 5 channel Tiff



Is it possible to save a 5 channel tiff? I start with a 4-channel 16-bit tiff image. I create 2 sets of objects, create outlines of one of the objects, and then crop everything based on the other. I want to add the outline image as a 5th channel and save the whole thing as a tiff. I’m expecting at the end a 509x568x5 (xyc) tiff. Instead, I’m getting a 5x509x568 image (5 pixels across, 509 down, and 568 z or t steps).

The export works perfectly if I only use 4 channels (including 3 colors + outlines) and it gives the same error if I use 5 normal image channels, so the problem is in saving the tiff and not in generating the outline image. I’m using version 3.0.0.

Does anyone know how to make it save correctly? Or, if not, does anyone know a way in ImageJ to swap x and c?



That sounds like a bug, can you upload a pipeline and image for us to try to reproduce?


The pipeline and example images are attached. (This is my first time posting to the forum, please let me know if I uploaded these incorrectly).


5channel.cpproj (793.3 KB)


Hi Sara,

Thanks for the pipeline and images, I ran them and had the same issue so as Beth said seems like this is a bug.

I have therefore logged it on Github as an issue and you can follow the progress there.