Bug in SaveImages

Hi,

I am experiencing a bug with SaveImages when I try to save .tif images.

Traceback (most recent call last): File "/home/hmary/CellProfiler/CellProfiler-11282/cellprofiler/pipeline.py", line 313, in run self.module.run(self.workspace) File "/home/hmary/CellProfiler/CellProfiler-11282/cellprofiler/modules/saveimages.py", line 449, in run should_save = self.run_image(workspace) File "/home/hmary/CellProfiler/CellProfiler-11282/cellprofiler/modules/saveimages.py", line 493, in run_image self.save_image(workspace) File "/home/hmary/CellProfiler/CellProfiler-11282/cellprofiler/modules/saveimages.py", line 848, in save_image return self.save_image_with_bioformats(workspace) File "/home/hmary/CellProfiler/CellProfiler-11282/cellprofiler/modules/saveimages.py", line 726, in save_image_with_bioformats channel_names = channel_names) File "/home/hmary/CellProfiler/CellProfiler-11282/cellprofiler/modules/saveimages.py", line 602, in make_metadata imeta = createOMEXMLMetadata() File "/home/hmary/CellProfiler/CellProfiler-11282/bioformats/metadatatools.py", line 27, in createOMEXMLMetadata return jutil.static_call('loci/formats/MetadataTools', 'createOMEXMLMetadata', '()Lloci/formats/meta/IMetadata;') File "/home/hmary/CellProfiler/CellProfiler-11282/cellprofiler/utilities/jutil.py", line 415, in static_call raise JavaException(jexception) JavaException: ()Lloci.formats.meta.IMetadata;

I have the feeling it’s related with javabridge. Look like CP is looking for java module… The strange thing is CP 10971 is running perfectly with my pipeline but I have this bug with revision 11282.

Here you have some specifications or the machine where I run CP:

  • CellProfiler lastest revision (11282)

  • Linux 2.6.38-10-generic #44-Ubuntu SMP x86_64 GNU/Linux

  • sun-java6 packages installed

  • Python 2.7.1+

Thanks a lot for your help !
hadipipe.cp (18.1 KB)

CP did not find my java installation… By setting variable properly, all is working fine now… Sorry for this useless post. You can delete it if you want :smile:

Cheers,

Good to hear that you solved the problem. I’m going to leave the post up for the benefit of others how may run into the same issue :smiley:
-Mark