Bug in ImageJ>Import>Import Sequence

Hi mighty developers,

I found a little strange behavior in the Image Sequence Import Dialogue (english Win10, FIJI with ImageJ 1.52k, german keyboard). I wanted to use regular expressions. When I tried to write a NOT with a [^] key in the “File name constraints”-Inputbox, it worked. But afterwards [SHIFT] and [ALTGR] Key combinations do not work anymore. [SHIFT]+[1] gives 1 instead of the expected ! . [SHIFT]+[a] still results A, normal characters key work as expected with [SHIFT], but not with [ALTGR] and also not for german “Umlauts” [ä][ö][ü]. But most importantly I cannot access brackets {[()]} anymore.
I could repeat this on other computers. But maybe it is connected to german settings?
A workaround is restart imageJ or copying the regex from an text editor.

If you press [^] in the other input boxes it has no effect. but once it is pressed as above it effects all others (of course there only numbers are relevant).

grafik
grafik

Nothing urgent but unexpected behavior :slight_smile:

Thanks for FIJI and ImageJ,
Torsten

2 Likes

I can confirm the behavior: for numbers and symbols, the Shift key seems to be ignored.
@Wayne can you comment if anything recently changed with regard to key listeners in dialogs?


@TorCK As a workaround, you can type your pattern in your favorite text editor, copy it, and then use CtrlV to paste it into the text field.

1 Like

Thanks for the fast answer. Exactly, copying from a texteditor works as workaround.

I am unable to reproduce this problem. The SHIFT key continues to work as expected after I use the File>Import>Image Sequence command with “(^*.tif)” entered into the “File name contains” field. I am using a U.S. keyboard and running ImageJ on macOS.

I can confirm that it works as expected on Mac OSX, also with a German keyboard layout.

The computer where I reproduced the issue reported by @TorCK was running Windows 7 and an up-to-date Fiji installation.

It works as expected for me on Windows 10 with a U.S. keyboard.

Thank you for looking into this!

I checked it with an older version of ImageJ 1.50e on the same computer (Win10, german keyboard) and there it worked normal as expected.
grafik
Version ImageJ 1.52c worked fine on Win7, german keyboard
grafik

The strange behaviour appears
with an newer version of ImageJ 1.52g on a Win Server Standard 2012, german keyboard.
grafik
with an newer version of ImageJ 1.52i on a Win7 Pro, german keyboard
grafik .

It seems to be connected to Java 1.8 and a german keyboard.

Then I tested the newest version 1.52i on a Win7 machine with US english settings and english keyboard.
This worked nicely.
I changed to german keyboard settings (same keyboard) on this machine -> strange behaviour.
It seems that the result of pressing the key ` mapped to ^ with german keyboard settings leads to this behaviour.

The very same thing with version 1.50e gave no strange behaviour.

Maybe this helps :slight_smile:
Best regards,
Torsten

1 Like