Brush Tool becomes slow after increasing RAM from 9 to 22GB

Hallo Pete,

I bought more RAM and increased the available RAM for QuPath (0.1.2) from 9 to 22 GB RAM.
After that, I observed the Brush tool becomes much slower and tends to have long breakes during annotating. Interruptions of up to 5-10 seconds quite often.

Is that an expected behavior or mayby this can become better with changing any other setting on top?

best
David

Hi David, it isn’t expected behavior but I don’t know of any setting you could change (other than reducing the RAM again). It is expected that the behavior is slow in v0.1.2 if there are many objects.

There will be no further development/fixes for v0.1.2, and since it is from 2016 it’s hard to remember enough of the code to offer much support. v0.2.0 was released in May; I’d recommend trying that where possible.

Hi Pete,

thank you for your Feedback. I solved the issue be reducing the RAM back to 9 GB. That works.
I plan to switch soon to v0.2.0. Already learning and exploring the functions and the scripting there.
I recognized that the polygon tool in v0.2.1 has the same tendency to break up if the first 2 points are clicked with high frequency. This was also an issue in the ealy days of QuPath 0.1.

best
David

I don’t recall this ever being reported and I’m not entirely sure what you mean. If you double-click with the polygon tool, no polygon is created (or, rather, an empty polygon is created and then immediately removed). This is intended behavior to avoid creating empty objects by accident, because a double-click is the way to complete a polygon annotation.

Is this the behavior you’re referring to?

1 Like

No i do not mean double click on one position.
It happens only in the very beginning of an annotation if I annotate a lot and try to be fast. The interruption happens usually after 3 to 7 polygon points. I´d rather say that I do not click exactly the same place.
I repored that in the early QuPath days and it was fixed very fast.

I can’t replicate any issue, but if I start annotating very quickly then the initial points can be created using click + drag. This activates an alternative polygon drawing mode (freehand), and the annotation is complete when the mouse button is released.

The documentation didn’t describe this, so I’ve updated it now: https://qupath.readthedocs.io/en/latest/docs/starting/annotating.html#polygon-polygon-tool

ok. Thank you.
I assume that is the reason for the break ups.
On my computer this hapens automatically very often, also if i do not continuously hold the mouse button.
There is a lag phase after the first polygon point of roundabout 0.25 seconds. I don´t know what QuPath computes in this moment, but if i move the mouse and and another polygon point in another position in this timewindow, i struggle with a lot of break ups. The only way to prevent it, is to wait after the first polygon point.
This is not the case anymore in QuPath 0.1.2.

Do you mean v0.2.1?
Or is v0.1.2 behaving better than v0.2.1 in this?

v 0.1.2 is behaving better than the new 0.2.1.
I can even not replicate the problem in 0.1.2.
The only difference between 0.1.2 and 0.2.1 on my computer is, that I downloaded the ZIP for 0.2.1 for testing, since I can not install both versions with msi (at least I believe that is not possible).

It shouldn’t matter if you use the exe or the msi.

I still can’t understand precisely what the problem is. If the initial bug report (that was fixed) is online, can you provide a link?

I tried to find the official bug report already. I guess my user Account was named DavidMHaumann in this time. But a filter with my name on Github did not work. I did not find it going to the oldest closed issues.
Also I am not shure if I directly wrote you an email in this time.
If you like, I can send you a link to share my screenshot with you.

I don’t have much time to look into this, but if you can give really clear, step-by-step instructions to reproduce the issue and what precisely happens then perhaps either @melvingelbard may be able to resolve it.

Some questions:

  • What exactly do you mean with ‘break up’ (e.g. stops annotating the polygon, creates two polygons… or something else)?
  • Can you reproduce the issue consistently?
  • Does it happen even without any other objects in the image, or only if other objects exist?
  • Does simply starting an annotation more slowly resolve the issue?

Shure.
About the questions:

What exactly do you mean with ‘break up’ (e.g. stops annotating the polygon, creates two polygons… or something else)?

==> The annotation is closed = finished. A single small annotation is created.

Instruction:
I happeny very regular short time after starting an annotion. Often, several vertex points are generated at the beginning, even if I click only 1 time and begin to move the mouse. The break up/closing of the annotation can happen even without a second click.

The problem can be avoided by annotating very slow.
Question: The issue has now a headline coping with RAM effects. Shall I open an issue in github with the headline "Polygon tool closes in short after beginning to annotate?

Can you reproduce the issue consistently?

==> yes.
Does it happen even without any other objects in the image, or only if other objects exist?
==> yes.
Does simply starting an annotation more slowly resolve the issue?
==> No. Only sometimes.

The problem appeary with all tested image formats till now.

Thanks for the extra info, I think I can replicate it and may have a fix but it needs a bit more testing.

The problem does seem connected to freehand mode. You can turn this off entirely in the preferences if you like.

1 Like

that sounds great. I´d like to try that but did not find the corresponding checkbox I need to deactivate. What is it´s name?

ah found it, not using the “drawing tools” but the whole list of preferences. “Enable freehand mode for polyon & polyline tools”.

This indeed solves the problem. I am happy! Thank you.

2 Likes