Black image for CLIJx Label classification (Weka)

Hey there @haesleinhuepf

After your recommendation I’ve been playing with CLIJx assistant and the labelling tools, which have been great fun, so thanks! I have come into some issues though.

I’ve been trying the weka label classifier (Label classification (Weka) | CLIJx-assistant) and I’ve been unable to use it because all I get is a black image, so cannot select anything to train! I’ve tried updating my drivers , images of different bit depths (8, 16, 32). Any more suggestions would be appreciated!

Ubuntu 20.04 Nvidia GTX 860M (tried drivers: 450 and 460 though I don’t have problems with other CLIJ operations)

.

Jim Rowe

Hey @JimageJ1 ,

from your screenshot, I’m guessing you didn’t annotate anything yet? A black window is basically the starting point. After annotation and training, results will show up. Otherwise, if an error message shows up I might be able to tell what’s going wrong. Have you tried clicking on “Train classifier”?

Cheers,
Robert

2 Likes

Wonderful! That’s where I was going wrong! Thanks!

1 Like

Awesome!

On a different note: I’m currently reworking + extending the list of potential “Features…”. If you would like to see something specific in there, please let me know!

1 Like

Variance of the Laplacian if it is not already there? Been a fan of that for blur detection, though I am sure there are other options for edge detection.

1 Like

Interesting! StdDev of intensity is in. StdDev of an edge-image sounds interesting! I think I will just implement it. Just to see what it does :grin: Thanks for sharing the idea!

1 Like

Used it a while ago to find blurred areas in whole slide scans (QuPathy stuff, of course). Not sure how it compares to other blur detection though.

1 Like