Bioformats TIF loader opens xyt, ImageJ1 xyz

I just got a bunch of tif files where this is the case. Sure enough, @StephanPreibisch’s stitching uses Bioformats to open these files such that everything goes south. The blackbox/ no-clue solution is to open all files with ImageJ1 and resave which fixes the issue. But it is a lot of files and duplicating data is stupid. I am suspecting a missing tif tag and different default behavior in Bioformats and ImageJ. Which tag could I set with which tool to fix this in minimal time?

Thanks as always,
Stephan

Vanilla TIFF does not support labeling dimensional axes. Two initial options which occur to me:

  • Save as an ImageJ (1.x) flavored TIFF, with dimensional metadata in the TIFF comment.
  • Save as OME-TIFF, with OME-XML in the TIFF comment.

Here is the ImageJ format:

ImageJ=1.44o
images=510
channels=2
slices=5
frames=51
hyperstack=true
mode=composite
unit=um
finterval=0.14285714285714285
loop=false
min=1582.0
max=6440.0

In ImageJ tradition, most of those fields are not required and have sensible defaults.

OME-TIFF is more complex but also more metadata-rich; see the OME-TIFF specification for details.

For either of these options, you may be able to surgically alter your original TIFF, rather than rewriting it completely. If your TIFFs are huge, this may be a time-saver. Happy to elaborate further if needed.

One other comment: Bio-Formats does have a certainty flag for each dimensional axis, indicating whether it is sure that its guess for that axis is correct. In the case of TIFF, the answer for that T dimension is definitely NO. So another option here would be to update the Stitching plugin to be more cautious about dimensions which are classified as uncertain.

1 Like