Bioformats Save crashes in Fiji and ImageJ GUI

Sample image and/or macro code

clipped from macro:
run("OME-TIFF...", "save=" + dir2+File.separator+name+"_"+j+".tif" + " compression=Uncompressed");

Background

  • Fiji or ImageJ hangs when trying to save as OME-tiff using the GUI but works when running in a macro with the above line. I’ve chosen the same settings as the macro code above (all in one file save, uncompressed) when asked. I’ve tried using the file menu ‘File-Save As- OME-TIFF…’ and ‘Plugins-Bioformats- Bioformats Exporter’ and both do the same. It gives the error:

loci.formats.UnknownFormatException: Unknown file format: /Users/glyn_nelson/Desktop/test3
at loci.formats.ImageWriter.getWriter(ImageWriter.java:158)
at loci.plugins.out.Exporter.run(Exporter.java:343)
at loci.plugins.LociExporter.run(LociExporter.java:75)
at ij.plugin.filter.PlugInFilterRunner.processOneImage(PlugInFilterRunner.java:265)
at ij.plugin.filter.PlugInFilterRunner.(PlugInFilterRunner.java:114)
at ij.IJ.runUserPlugIn(IJ.java:235)
at ij.IJ.runPlugIn(IJ.java:196)
at ij.Executer.runCommand(Executer.java:150)
at ij.Executer.run(Executer.java:68)
at java.lang.Thread.run(Thread.java:745)

But only the first time you do it- if you try again, Fiji/ImageJ hangs.

The only way I got it to work was to specify the file suffix ‘.tif’ in the filename Save dialogue- if I choose the filetype from the dropdown (ome.tif) option in the Save dialogue box, it gives the error types described above.

I have up to date ImageJ and Fiji, java 8 and up to date stable builds of Bioformats in both.

Is this a Mac specific fault, me specfic fault, or have others seen similar/ can reproduce?

Glyn

Hi Glyn, I have managed to reproduce the same error. It looks as though selecting the format from the drop down box in the Exporter is not populating the file extension correctly. If you manually add the extension to the filename when saving (so test3.ome.tiff rather than just test3) then that should allow you to export it correctly as a work around.

1 Like