Bio-formats fails with brackets in image name if used in a macro but not when using plugin UI


I have .im3 multispectral images that are essentially a stack of 21 tiff images. I can open them using bioformats thru the plugin menu GUI:

Yet, if I use the recorded command in a macro it fails even though it the computer appears to have plenty extra and Fiji memory is also set to have more then enough:

Any suggestions on what might be the problem? I tried ‘color_mode=Color’ and ‘Greyscale’, but the same error occurred.

thanks in advance! John

Ok, it appears the problem is with the brackets in the name.

This works:

this does not:

The images I’m trying to process are from a PerkinElmer Vectra. They are .im3 or InForm format multispectral images. The brackets in the name are added at creation and enclose the x,y position of the image.

Something appears to have changed with Fiji or bio-formats (or Java who knows…) as I was able to process images named this way in September of last year (2018).


There was a related problem with macro parameters containing brackets, see this discussion:

It should have been fixed (but maybe not in all places):

But the fact you get an <Out of memory> error seems to point at an issue with bio-formats as well.

If you are seeing the Out of memory issue with large files I would recommend using the option ‘Use Virtual Stack’ when importing with Bio-Formats.