Bigwarp not loading all .tif files

Hello,

I am trying to align two .tif files generated at different times but on the same section in order to determine colocalisation of signal. I am trying to use bigwarp to do this. I open both the .tif files and start the plug in. However, there is an issue with one of the tif files. When I select it as the fixed image, it does not display within the dialogue box and when I select it as the moving image, I get the error below:

(Fiji Is Just) ImageJ 2.0.0-rc-67/1.52h; Java 1.8.0_172 [64-bit]; Windows 10 10.0; 8556MB of 12166MB (70%)
 
java.lang.ArrayIndexOutOfBoundsException: 7
	at bigwarp.BigWarpInit.namesFromImagePluses(BigWarpInit.java:513)
	at bigwarp.BigWarpInit.createBigWarpDataFromImages(BigWarpInit.java:406)
	at bdv.ij.BigWarpImagePlusPlugIn.run(BigWarpImagePlusPlugIn.java:79)
	at ij.IJ.runUserPlugIn(IJ.java:228)
	at ij.IJ.runPlugIn(IJ.java:192)
	at ij.Executer.runCommand(Executer.java:137)
	at ij.Executer.run(Executer.java:66)
	at java.lang.Thread.run(Thread.java:748)

Could anyone offer some advice on how to fix/troubleshoot please? I have updated imagej, tried using a smaller version of the tif file and am able to transform other images. I’m new to image analysis/manipulation so obvious/baisic suggestions welcome! Thanks in advance.

Best,
Dave

2 Likes

Are you using multi-channel images with different numbers of channels?

I looked at the bigwarp version that ships with Fiji (3.1.2) and found these lines in BigWarpInit.namesFromImagePluses:

String[] names = new String[impP.getNChannels() + impQ.getNChannels()];

String[] impPnames = namesFromImagePlus(impP);
String[] impQnames = namesFromImagePlus(impP);

The names array has the correct size, but impQnames is generated with the wrong size from impP instead of impQ. if impQ has more channels than impP, this would cause the exception that you see. This is fixed on the current master branch and maybe in a previous release but I do not know when the fix will be available through Fiji. Maybe it is possible to just download the jar and replace the current jar in your Fiji.app/plugins directory but @bogovicj will know best!

Update: I just saw that the bug is fixed in 4.0.0 but I do not know the timeline for an update of the bigwarp version in Fiji.

2 Likes

Hi @degrainger,

Welcome to the forum.

Updating Fiji will probably fix this issue. Help > Update...

If it doesn’t try the steps below. Please post back both if you continue to experience issues and if you managed to get things working.

John

If updating didn’t work

Check what version of bigwarp you have (it should be 5.0.0). You can do this by

  1. Looking at the name of the bigwarp file in your Fiji.app/plugins folder. It’ll look like bigwarp_fiji-x.y.z.jar
  2. Use the gui
    a) Help > Upate..,
    b) Advanced mode
    c) set View Options to View all files
    d) Search for bigwarp
    e) clicking the bigwarp_fiji file should show what version you have (see screenshot)

Details

@hanslovsky is 100% right about the cause of this bug (and that it was fixed).

Fortunately, Fiji now ships with bigwarp 5.0.0 (since June 2019), which means that you’re probably using an out-of-date bigwarp version.

2 Likes

HI @bogovicj and @hanslovsky,

Thank you both for your quick responses. They were both very helpful and I now have resolved the issue through updating Fiji. Apologies for the delay in getting back to you. Thanks again :smiley:

Best,
Dave

2 Likes

Glad that this solved your issue @degrainger. You can mark any answer (probably @bogovicj’s answer is most appropriate) as the solution. This will do two things:

  1. It will mark the topic as solved
  2. It will directly link to the solution and people with similar issues will be able to find a solution more quickly