Behaviour of Interactive Marker-controlled watershed (MorphoLibJ) in macro

Dear all,

I would thank any help with this code below.

Sample image and/or code

                   // already opened image to be segmented, and renamed as "CH1"
		rename("CH1");
		// pluggin
             
		run("Interactive Marker-controlled Watershed"); //open pluggin interface
		selectWindow("Marker-controlled Watershed");
		setTool("multipoint");
		run("Brightness/Contrast...");
		run("Enhance Contrast", "saturated=0.35"); //just to see better
		waitForUser("Click each cell with mouse, and press OK"); //here user has to select each cell with multipoint tool
		call("inra.ijpb.plugins.InteractiveMarkerControlledWatershed.segment", "calculateDams=true", "connectivity=4"); 
		call("inra.ijpb.plugins.InteractiveMarkerControlledWatershed.setDisplayFormat", "Watershed lines");
		call("inra.ijpb.plugins.InteractiveMarkerControlledWatershed.toggleOverlay");
		selectWindow("CH1-watershed-lines");
		call("inra.ijpb.plugins.InteractiveMarkerControlledWatershed.createResultImage");

Background

The image is just as following example
imagen
Just an image of cells to be segmented

Analysis goals

The pluggin is working perfectly in manually mode, but when try to use it in a macro:

1.- instruction: call(“inra.ijpb.plugins.InteractiveMarkerControlledWatershed.segment”, “calculateDams=true”, “connectivity=4”); works properly and opens the interface with selected image
but,

2.- instruction: call(“inra.ijpb.plugins.InteractiveMarkerControlledWatershed.segment”, “calculateDams=true”, “connectivity=4”); doesn’t do anything
If I do this manually, works; but automatically through macro instructions, no reaction.

Is anyone available to help me with this code, please?

Thank you so much
Olga