Ashlar alignment program only aligning rows

Hello!

I’m trying to use Ashlar to stitch together an ome-tif. BigStitcher in Fiji successfully aligns the tiles in my file but, Ashlar is outputting a strange, seemingly incomplete product.

BigStitcher outcome:


image

Ashlar outcome:


image

I am starting with a czi file and use bftools to convert it to an ome-tif.

bfconvert -option zeissczi.autostitch false input.czi output.ome.tif

I get the same result if I use bioformats importer/exporter in Fiji.

I am running macOS 10.15.5. I installed pyfftw with conda as recommended on the github page.
I get the exact same result with my image if I run it through Ashlar in the docker container (see the Dockerfile on the github page).

Does anyone have any clue what is going on?

Hi Tim, I only just realized people were asking Ashlar questions here. I hope this response doesn’t come too late for you.

Your problem should be fixed by adding the --flip-y argument to ashlar, which is required when the microscope’s stage “up” direction is inverted with respect to the image “up” direction. I don’t have access to enough microscopes to determine how this setting varies across vendors or models, but it should at least be constant for an individual instrument. Once you know you need --flip-y for that scope, I expect you will always need it.

Another tip: You can just pass Ashlar the input.czi file directly, no need to convert to OME-TIFF. Make sure you update to at least Ashlar v1.13.0 (the latest as I write this) as that version adds a critical fix to how we read .czi files with BioFormats.