Artifacts in corner of image when identifying objects

Hi,

I have a DAPI image of a Bacillus subtilis strain that I’d like to identify objects on. So far it has managed to pick up a decent bunch of objects, but I keep getting a group of false positives where there really isn’t anything (the square of objects in the upper right corner). Any idea how to get rid of this while still retaining the nicely outlined cells? I suppose I could filter them out at a later stage, but it seems odd that they were identified in the first place, really.

Cheers,
Simon
identifyDapi.cp (3.29 KB)



Hi Simon,

This artifact is a consequence of the adaptive thresholding method. This approach tiles the image into non-overlapping block and thresholds each individually. Unfortunately, if the block has no foreground, the threshold can becomes too low and end up identifying false positives, as you discovered.

One straightforward way to avoid this is to set the lower threshold bound to the lowest grayscale value that you think represents the foreground. However, I think a better way to improve identification in general for your images is the following:

  • Insert an EnhanceOrSupressFeatures module prior to the IdentifyPrimaryObject module. Set the filter size to approximately the typical pixel width the bacillus objects (perhaps 15-20 pixels)
  • Use the output of this module as the input into the IdentifyPrimaryObject module.
  • Change the IdentifyPrimaryObject module threshold settings to Otsu global, three class thresholding, with the middle class set to “Background”

You can use the object diameter settings to get rid of the remaining spurious false positives.

Regards,
-Mark

Thanks, that gave much better results! :mrgreen: