Adiposoft - debug DIY



Hi all,

I’m using the Adiposoft plugin for cell size analysis ( It generally works great, but when trying to run batch analyses, I get the following error “no window with the title “total” found”. This has just started happening even though the same installed version was working a few days ago. I’ve tried reinstalling but, oddly, the issue persists. If I process images one by one, the software works perfectly. I’ve also tried the Linux version, and I get exactly the same issue.

Any ideas on where to look? I’ve contacted the developers, but I’m trying to figure this out myself as I’m not sure how well supported the plugin is these days. I can post the code if that would help, but I’m not sure which script would be the most helpful. I’m guessing the “Adiposoft.ijm”? It just seems like it can’t locate the proper directory or something in batch analysis.

Any help greatly appreciated.


Error Message ImageJ Fiji

Welcome to the forum, @Luke_Norton!

FWIW, I invited the authors to this forum discussion using the Invite button. Let’s see how responsive they are.

Yes, the Java class in the provided jar file simply wraps around this Adiposoft.ijm macro file, so all the functionality is in there.

What is the full error message? Does it specify a line number?


Thanks! The specific error message is exactly that. No line numbers. Nothing. The title of the box says “Macro Error” and then the error message stated above. Let me know if it would be helpful to post the code.


Hi Luke,
I’m currently the maintainer of the plugin, although I didn’t develop it. Unfortunately, the person who developed it doesn’t work here anymore, so it is a bit more complicated for me to go through the code. I’m trying to figure out where the problem may come from, since the batch processing was working fine not long ago, as you already said. I will let you know as soon as I manage to solve the problem.

Error Message ImageJ Fiji

Hi Mikel,

Any update on what can be done about this error?

Thank you.
Best wishes,


Hi Luke, Sheroz, and all,

I’ve finally managed to fix the bugs and get an Adiposoft version that works fine with the latest Fiji build. You can download the new plugin from the webpage (

I’m sorry for the delay, I hope you still find the tool helpful for your analysis.



Hi @mikelariz,

thank you very much for maintaining this plugin.

Did you consider using an update site to distribute it? That would make installation a lot easier for users, and you could make sure that new versions automatically get distributed to all users who subscribed the update site. :slight_smile:

On a related note: is the source code for this plugin available on github or bitbucket? If so, I’d like to add this information to the info box on the wiki page. Having the source available under a permissive license would allow members of the community to assist with maintenance by fixing bugs in response to error reports, and by submitting pull requests.


Hi Jan,

I’ll have a look into it and try to create an update site then, ok.

The source code is not available on those platforms, but all the processing is done in the macro that can be accessed by unzipping the jar file. I’ve never used github or bitbucket for posting source code, but I can take a look into it if that’s better.


Hey Mikel,

Apologies for the delay. Thanks for update. I will give the new version a try,